Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-25145

CRON error: User ID does not exist or is deleted!

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 2.0
    • Fix Version/s: 2.0
    • Component/s: Other
    • Labels:
      None
    • Environment:
      Linux/Apache with Moodle 2.0 RC1 (Build: 20101110)
    • Database:
      MySQL
    • Affected Branches:
      MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE

      Description

      I set up a CRON job in cPanel on my server. It tries to run but it stops at enroll_meta . This may be related to a Restore issue reported at MDL-23898.

      This is the email report that cPanel sends me concerning the CRON job:

      X-Powered-By: PHP/5.2.9
      Content-type: text/html

      Server Time: Wed, 10 Nov 2010 14:30:05 -0600

      Cleaning up stale sessions
      Starting activity modules
      Processing module function assignment_cron ...... used 3 dbqueries
      ... used 0.054461002349854 seconds
      done.
      Processing module function chat_cron ...... used 5 dbqueries
      ... used 0.0093538761138916 seconds
      done.
      Processing module function forum_cron ...Starting digest processing...
      Cleaned old digest records
      ... used 3 dbqueries
      ... used 0.0056829452514648 seconds
      done.
      Finished activity modules
      Starting blocks
      Processing cron function for rss_client....
      0 feeds refreshed (took 0.001264 seconds)
      done.
      Processing cron function for search....Global searching is not enabled. Nothing performed by search.
      done.
      Finished blocks
      Starting quiz reports
      Finished quiz reports
      Starting admin reports
      Finished admin reports
      Starting main gradebook job ...
      done.
      Starting processing the event queue...
      done.
      Running auth crons if required...
      Running enrol crons if required...
      Running cron for enrol_meta...
      !!! Coding error detected, it must be fixed by a programmer: User ID does not exist or is deleted! !!!

      I don't know if this is a Moodle 2.0 bug or just a database error that I need to correct. I have looked at the database and I can't see what needs to be fixed.

      Thanks,
      Clarence

        Attachments

          Activity

            People

            Assignee:
            skodak Petr Skoda
            Reporter:
            cprudhoe Clarence Prudhoe
            Tester:
            Nobody
            Participants:
            Component watchers:
            Adrian Greeve, Jake Dallimore, Mathew May, Mihail Geshoski, Peter Dias
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Fix Release Date:
              24/Nov/10