Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-25186

Create one enviromental check to recommend PHP >= 5.3.3 on install/upgrade

    XMLWordPrintable

    Details

    • Difficulty:
      Easy
    • Affected Branches:
      MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_19_STABLE, MOODLE_20_STABLE

      Description

      While PHP 5.2.8 is the hard (required) min version to run Moodle 2.0, I think it could be interesting to add one new environmental test to be executed on each install / upgrade:

      • Create it as custom and optional check.
      • Make it look for PHP 5.3.3
      • If the test pass, remain hidden.
      • If the test fails, inform about the benefits (memory/speed/security) of using PHP 5.3
      • Make the test available also in 19_STABLE (but apply it only to 2.0 version)

      I think it can be interesting to have that being informed continuously to admins. Differences are huge enough.

      Ciao

        Attachments

          Activity

            People

            Assignee:
            rwijaya Rossiani Wijaya
            Reporter:
            stronk7 Eloy Lafuente (stronk7)
            Participants:
            Component watchers:
            Andrew Nicols, Jun Pataleta, Michael Hawkins, Shamim Rezaie, Simey Lameze
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Fix Release Date:
              21/Feb/11