Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-25196

1.95+ Upgrade Causes "Error Reading from Database"

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Major
    • Resolution: Duplicate
    • 1.9.5
    • None
    • Database SQL/XMLDB
    • None
    • MySQL
    • MOODLE_19_STABLE

    Description

      After running upgrade for Moodle 2.0 from 1.95, the following error occurs.

      Debug info: Unknown column 'a.question' in 'on clause'

      SELECT qa.*, q.qtype
      FROM mdl_question_answers qa
      JOIN mdl_question q ON a.question = q.id
      [array (
      )]
      Stack trace:

      • line 391 of /lib/dml/moodle_database.php: dml_read_exception thrown
      • line 691 of /lib/dml/mysqli_native_moodle_database.php: call to moodle_database->query_end()
      • line 5068 of /lib/db/upgrade.php: call to mysqli_native_moodle_database->get_recordset_sql()
      • line 1309 of /lib/upgradelib.php: call to xmldb_main_upgrade()
      • line 264 of /admin/index.php: call to upgrade_core()

      Attachments

        Issue Links

          Activity

            People

              timhunt Tim Hunt
              tguy890 Timothy Guy
              Nobody Nobody
              David Woloszyn, Huong Nguyen, Jake Dallimore, Meirza, Michael Hawkins, Raquel Ortega, Safat Shahin, Stevani Andolo
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: