Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-25232

Q&A Forum's "Subject(hidden)" mechanism unexpectedly hides blocks

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0
    • Fix Version/s: 2.0.2
    • Component/s: Unknown
    • Labels:
      None
    • Environment:
      Ubuntu, Firefox 3.5.9, Arialist theme
    • Database:
      MySQL
    • Affected Branches:
      MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE

      Description

      The "Subject(hidden)" mechanism in Q&A forum unexpectedly hides site-wide and course-specific any-page visible blocks. All expected blocks reappear once "Reply" is selected, and blocks behave as expected once "Subject(hidden)" no longer appears to the user.

      Procedure to reproduce this bug:
      0) (set at least one front page or course block as visible on any page)
      1) In a course, create a Q&A discussion forum
      2) Post a new discussion in the Q&A forum
      3) Post a reply to the discussion
      4) Login as a different user with student access to that forum (i.e. as a user who will see "Subject (hidden)" until he replies to the original post)
      5) View the discussion and note that blocks suddenly do not appear on the view discussion page
      6) Reply to the original post and note that expected blocks are again visible

        Gliffy Diagrams

          Activity

          poltawski Dan Poltawski added a comment -

          Thanks for the report.

          This bug was caused by the hidden block section not generating complaint html. There was an unmatched div. I have created PULL-92 to get a fix to this merged

          tsala Helen Foster added a comment -

          Thanks Thomas and Dan.


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Fix Release Date:
                21/Feb/11