Moodle
  1. Moodle
  2. MDL-25248

1.9->2.x upgrade: Unknown error upgrading mod_resource to version 2009062600, can not continue

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.0
    • Fix Version/s: 2.2.11
    • Component/s: Unknown
    • Labels:
      None
    • Environment:
      cPanel access.
    • Database:
      MySQL
    • Testing Instructions:
      Hide

      1/ install 1.9.x and all different resource types
      2/ add several more resources
      3/ go to DB and change the last two course_modules.instance fields to point to different resource (one from the same, other from different course)
      4/ upgrade to 2.2.x
      5/ verify the resources were upgraded correctly

      Show
      1/ install 1.9.x and all different resource types 2/ add several more resources 3/ go to DB and change the last two course_modules.instance fields to point to different resource (one from the same, other from different course) 4/ upgrade to 2.2.x 5/ verify the resources were upgraded correctly
    • Affected Branches:
      MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_22_STABLE
    • Pull from Repository:
    • Rank:
      5132

      Description

      Giving error during upgrade process.

      • line 154 of /lib/upgradelib.php: upgrade_exception thrown
      • line 107 of /mod/resource/db/upgrade.php: call to upgrade_mod_savepoint()
      • line 490 of /lib/upgradelib.php: call to xmldb_resource_upgrade()
      • line 265 of /lib/upgradelib.php: call to upgrade_plugins_modules()
      • line 1352 of /lib/upgradelib.php: call to upgrade_plugins()
      • line 302 of /admin/index.php: call to upgrade_noncore()

        Issue Links

          Activity

            People

            • Votes:
              13 Vote for this issue
              Watchers:
              18 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: