Moodle
  1. Moodle
  2. MDL-25352

Empty HTML Blocks after using admin/replace.php

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 2.0
    • Fix Version/s: 2.0.3
    • Component/s: Administration, Blocks
    • Labels:
    • Environment:
      LAMP
    • Database:
      MySQL
    • Affected Branches:
      MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE
    • Rank:
      2748

      Description

      After upgrading from 1.9.5+ to 2.0RC2+ latest, I noticed that HTML blocks were empty. For example, the site search using google custom search looks like as shown in the attachment.

        Activity

        Hide
        Petr Škoda added a comment -

        I ma sorry I can not reproduce this problem. This might be caused by PHP incompatibility or server configuration.
        Could you please provide detailed server configuration (PHP version, apache version, source of binary packages, etc.).

        Lowering priority because it does not seem other servers are affected.

        Thanks for the report and your cooperation.

        Petr Skoda

        Show
        Petr Škoda added a comment - I ma sorry I can not reproduce this problem. This might be caused by PHP incompatibility or server configuration. Could you please provide detailed server configuration (PHP version, apache version, source of binary packages, etc.). Lowering priority because it does not seem other servers are affected. Thanks for the report and your cooperation. Petr Skoda
        Hide
        Manish Verma added a comment -

        On more testing with 2.0 weekly it appears that the issue comes up not immediately after upgrade but after using replace.php.

        PHP version 5.2.13
        Apache version 2.2.15
        MySQL version 5.0.91-community-log
        Kernel version 2.6.18-194.11.4.el5

        Show
        Manish Verma added a comment - On more testing with 2.0 weekly it appears that the issue comes up not immediately after upgrade but after using replace.php. PHP version 5.2.13 Apache version 2.2.15 MySQL version 5.0.91-community-log Kernel version 2.6.18-194.11.4.el5
        Hide
        Manish Verma added a comment -

        This issue is there in moodle 2.0.1+ also, it appears that replace.php wips off content from HTML blocks.

        Show
        Manish Verma added a comment - This issue is there in moodle 2.0.1+ also, it appears that replace.php wips off content from HTML blocks.
        Hide
        Luciano Biondo added a comment -

        I'm using moodle 2.0.2 and bug is yet present.
        php 5.2.15
        mysql 5.1.52

        You suggest to upgrade from 1.9 to 2.0 in a server different from the production one... but how con i do? A server different has a different url!

        Show
        Luciano Biondo added a comment - I'm using moodle 2.0.2 and bug is yet present. php 5.2.15 mysql 5.1.52 You suggest to upgrade from 1.9 to 2.0 in a server different from the production one... but how con i do? A server different has a different url!
        Hide
        Luciano Biondo added a comment -

        My server is hostgator: a lot of people use it! Petr, I hope priority is stated very high.

        Show
        Luciano Biondo added a comment - My server is hostgator: a lot of people use it! Petr, I hope priority is stated very high.
        Hide
        Luciano Biondo added a comment -

        Bug is present even using my computer in local
        macosx 10.6.6
        php 5.3.3
        apache 2.2.15
        mysqli: mysqlnd 5.0.7-dev - 091210 - $Revision: 300533 $

        Show
        Luciano Biondo added a comment - Bug is present even using my computer in local macosx 10.6.6 php 5.3.3 apache 2.2.15 mysqli: mysqlnd 5.0.7-dev - 091210 - $Revision: 300533 $
        Hide
        Petr Škoda added a comment -

        Hopefully to be fixed in the next weekly build, thanks for the report.

        Petr

        Show
        Petr Škoda added a comment - Hopefully to be fixed in the next weekly build, thanks for the report. Petr
        Hide
        Helen Foster added a comment -

        Thanks everyone for your comments. Confirming that this issue is fixed in the latest 2.0.2+.

        Show
        Helen Foster added a comment - Thanks everyone for your comments. Confirming that this issue is fixed in the latest 2.0.2+.

          People

          • Votes:
            1 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: