Moodle
  1. Moodle
  2. MDL-25367

User images are not processed during MNet SSO

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.0
    • Fix Version/s: 2.0.1
    • Component/s: MNet
    • Labels:
      None
    • Affected Branches:
      MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE

      Description

      User images are now handled via File API. The MNet SSO code that synchronizes user images was just commented out and it does not work at the moment. For user experience it is important to transfer images again.

      Note there will be backward compatibility issue as since Moodle 2.0, user images are always converted to PNGs. If such file will be sent to Moodle 1.9, it will be probably saved with JPG extension.

        Gliffy Diagrams

          Issue Links

            Activity

            Hide
            David Mudrak added a comment -

            Hi Martin and Petr,

            I have fixed the issue with user images not being synced via MNet during SSO. During the work, I have noticed several other bugs in MNet SSO so I fixed them, too. The final patchset consists of 5 commits and you can see them at https://github.com/mudrd8mz/moodle/compare/cvshead...MDL-25367_mnet_user_images

            Works in Moodle 2.0 -> Moodle 2.0 and Moodle 2.0 -> Mahara 1.3 MNet setups. Moodle 2.0 is not able to sync images with 1.9 sites via MNet at the moment. That must be fixed in 1.9.11 (the reason is that 1.9 relies on f1.jpg contents of which never changes. This is not true any more because of optimization we perform on images and file api storage). Also, a patch for Mahara must be prepared so that their users can roam to Moodle 2.0. But these two can wait IMHO.

            I would really like to see this patchset in Moodle 2.0 as the fixes are pretty important. Please review and approve. TIA

            Show
            David Mudrak added a comment - Hi Martin and Petr, I have fixed the issue with user images not being synced via MNet during SSO. During the work, I have noticed several other bugs in MNet SSO so I fixed them, too. The final patchset consists of 5 commits and you can see them at https://github.com/mudrd8mz/moodle/compare/cvshead...MDL-25367_mnet_user_images Works in Moodle 2.0 -> Moodle 2.0 and Moodle 2.0 -> Mahara 1.3 MNet setups. Moodle 2.0 is not able to sync images with 1.9 sites via MNet at the moment. That must be fixed in 1.9.11 (the reason is that 1.9 relies on f1.jpg contents of which never changes. This is not true any more because of optimization we perform on images and file api storage). Also, a patch for Mahara must be prepared so that their users can roam to Moodle 2.0. But these two can wait IMHO. I would really like to see this patchset in Moodle 2.0 as the fixes are pretty important. Please review and approve. TIA
            Hide
            David Mudrak added a comment -

            Sent into CVS HEAD as agreed with Petr via Skype.

            Show
            David Mudrak added a comment - Sent into CVS HEAD as agreed with Petr via Skype.
            Hide
            Geoffrey Rowland added a comment -

            Hi David

            Re: "Also, a patch for Mahara must be prepared so that their users can roam to Moodle 2.0."

            I realise this may be outside the scope of this tracker if the patch needs to be applied at the Mahara end of things. However, are you aware of any progress with this? In testing XMLRPC SSO from Mahara 1.3.3 to Moodle 2.0.2, I'm not getting any transfer of profile images.

            Show
            Geoffrey Rowland added a comment - Hi David Re: "Also, a patch for Mahara must be prepared so that their users can roam to Moodle 2.0." I realise this may be outside the scope of this tracker if the patch needs to be applied at the Mahara end of things. However, are you aware of any progress with this? In testing XMLRPC SSO from Mahara 1.3.3 to Moodle 2.0.2, I'm not getting any transfer of profile images.
            Hide
            David Mudrak added a comment -

            Hi Geoffrey, you can check if that was already reported in Mahara tracker (http://bugs.launchpad.net/mahara) and eventually create a new issue for that. I'll be happy co-opearating with mahara team to fix this. Thanks.

            Show
            David Mudrak added a comment - Hi Geoffrey, you can check if that was already reported in Mahara tracker ( http://bugs.launchpad.net/mahara ) and eventually create a new issue for that. I'll be happy co-opearating with mahara team to fix this. Thanks.

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: