Moodle
  1. Moodle
  2. MDL-25406

Broken Wiki on Upgrade to Moodle 2.0

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 2.0
    • Fix Version/s: None
    • Component/s: Wiki (2.x)
    • Labels:
    • Environment:
      LAMP
    • Database:
      MySQL
    • Difficulty:
      Moderate
    • Affected Branches:
      MOODLE_20_STABLE

      Description

      After upgrading from 1.9.5+ to 2.0, one wiki of one course (say, course A) when clicked on points towards the wiki of another course (say, course B). Other wikis of the same course (i.e. A) do not behave in this manner. After the concerned wiki of course B is deleted from the test installation, the following error is thrown when the concerned wiki of couse A is clicked:

      Notice: Trying to get property of non-object in /moodle/mod/wiki/create.php on line 48

      wiki/invalidwikiid

      More information about this error (clickable, points to http://docs.moodle.org/en/error/wiki/invalidwikiid)

      Stack trace:
      line 421 of /lib/setuplib.php: moodle_exception thrown
      line 49 of /mod/wiki/create.php: call to print_error()

        Gliffy Diagrams

          Activity

          Helen Foster added a comment -

          Manish, when you say "one wiki of one course (say, course A) when clicked on points towards the wiki of another course" do you mean that the wiki includes a link to another wiki? Are all the other wikis upgraded without problems?

          Manish Verma added a comment -

          Helen, the wiki of course A had no connection with the other wiki. When I click on the main link of the wiki of course A, it simply goes to the wiki (edit mode) of course B. A user enrolled in course A, when clicks on that wiki does not see it displayed on click. The upgrade was smooth without any errors (debug was on).

          Helen Foster added a comment -

          Thanks for clarifying things Manish. I've just added a couple of 2.0 wiki experts as watchers for their input.

          Eloy Lafuente (stronk7) added a comment -

          Assigning to Dongsheng and raising to blocker. I thought I've done that some hours ago, but my (particular) problems with the Tracker seem that prevented the edition to happen.

          I'd say it is max priority to get this detected and fixed ASAP (yes, uppercase).

          Ciao

          Dongsheng Cai added a comment -

          Hi, Manish

          When you say 'main link', which link are you referring to? Can you please post a screenshot here? Is your website public?

          Manish Verma added a comment -

          Hi Dongsheng,

          By main link, I am referring to the link that is displayed on the course page which a user would click to view. I am sending you the concerned URLs via email shortly as there is test installation URL involved.

          Dongsheng Cai added a comment -

          Thanks Manish

          Dongsheng Cai added a comment -

          Hi all

          Thanks for Manish's course backup.

          The issues was caused by incorrect subwiki id (it was wrongly used wid instead).

          Dongsheng Cai added a comment -

          Fixed in cvs, feel free to reopen if you find any problem

          Manish Verma added a comment -

          Now, the concerned wiki on click does not go to another course's wiki. But is still not behaving the way it should. I did a fresh upgrade with the weekly 2.0 code and when I clicked on the main link to view, the create page of wiki was opened instead. Now, when I click to view, I see blank. The data can be seen by going to map and choosing another link there.


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: