Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-25414

DDL sql execution error on fresh install

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Cannot Reproduce
    • Affects Version/s: 2.0
    • Fix Version/s: None
    • Component/s: Installation
    • Labels:
      None
    • Database:
      MySQL
    • Affected Branches:
      MOODLE_20_STABLE

      Description

      With a fresh install of Moodle 2.0 (declared stable yesterday Nov 24th), I got a "DDL sql execution error"

      Debug info:
      Table 'course_completions' already exists
      CREATE TABLE course_completions (
      id BIGINT(10) unsigned NOT NULL auto_increment,
      userid BIGINT(10) unsigned NOT NULL DEFAULT 0,
      course BIGINT(10) unsigned NOT NULL DEFAULT 0,
      deleted TINYINT(1) unsigned,
      timenotified BIGINT(10) unsigned,
      timeenrolled BIGINT(10) unsigned NOT NULL DEFAULT 0,
      timestarted BIGINT(10) unsigned NOT NULL DEFAULT 0,
      timecompleted BIGINT(10) unsigned,
      reaggregate BIGINT(10) unsigned NOT NULL DEFAULT 0,
      CONSTRAINT PRIMARY KEY (id)
      ) ENGINE = InnoDB
      Stack trace:

      • line 397 of /lib/dml/moodle_database.php: ddl_change_structure_exception thrown
      • line 620 of /lib/dml/mysqli_native_moodle_database.php: call to moodle_database->query_end()
      • line 88 of /lib/ddl/database_manager.php: call to mysqli_native_moodle_database->change_database_structure()
      • line 75 of /lib/ddl/database_manager.php: call to database_manager->execute_sql()
      • line 456 of /lib/ddl/database_manager.php: call to database_manager->execute_sql_arr()
      • line 408 of /lib/ddl/database_manager.php: call to database_manager->install_from_xmldb_structure()
      • line 1247 of /lib/upgradelib.php: call to database_manager->install_from_xmldb_file()
      • line 169 of /admin/index.php: call to install_core()

      I deleted the tables that had been created up to the "course_completions" table several times but to no avail. The install consistantly stops at this point. When I press "Continue" I get a the message ""Could not find a top-level course!"

        Attachments

          Activity

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: