Moodle
  1. Moodle
  2. MDL-25436

workshop module list of assignments uses deprecate print_table() call [patch]

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0
    • Fix Version/s: 2.0.1
    • Component/s: Workshop
    • Labels:
      None
    • Environment:
      Apache, PHP 5.3.3-1ubuntu9, Postgres
    • Database:
      PostgreSQL
    • Difficulty:
      Easy
    • Affected Branches:
      MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE
    • Rank:
      1153

      Description

      When viewing the list of workshop assignments from the activities block, a deprecation warning is issued about using print_html() instead of html_writer::table().

      Steps to reproduce:
      1) create a course with one or more workshop assignments
      2) click on the workshop link in the activities block of the course page
      3) view the deprecation warning (when debugging is on)

      Attached is a best guess trivial patch that uses the suggested interface change. All output seems to be correct after the patch is applied.

        Activity

        David Mudrak added a comment -

        Fixed in CVS. Thanks for the report and for the patch!


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: