Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-25443

Gradebook issues with groupmembersonly

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Duplicate
    • Affects Version/s: 2.0, 2.7
    • Fix Version/s: None
    • Component/s: Gradebook
    • Labels:
      None
    • Database:
      Any
    • Affected Branches:
      MOODLE_20_STABLE, MOODLE_27_STABLE

      Description

      (This needs better description)

      Comments by Petr:

      • code change - hide inaccessible module instances on the reports reports for students/parents (optional)
      • docs - instruct teachers to groups the activities for different groups into special category/categories (use the same max grade)
      • docs - set up aggregation in this category to Average - set keephigh==1
        This approach is usable only if you divide the students into non-overlapping groups and create a separate grouping for each activity.

      The recommended workflow for teachers is:
      1/ create gradebook category "Separate assignments", set up average aggregation with keep high 1
      2/ create 4 groups and 4 groupings - add 1 group into each grouping (+ assign students to groups)
      3/ create 4 assignments - set groupmembersonly and set parent category

      I can not see any way to automate this complex process, I personally think it is better to educate teachers instead.

        Gliffy Diagrams

          Issue Links

            Activity

            andyjdavis Andrew Davis added a comment -

            Hello. I will not be able to work on this issue in the immediate future. In order to create a truer sense of the state of this issue and to allow other developers to have chance to become involved, I am removing myself as the assignee of this issue.

            For more information, see http://docs.moodle.org/dev/Changes_to_issue_assignment

            If you have any ideas about this issue or a possible solution please post it here

            marina Marina Glancy added a comment -

            closing as a duplicate of MDL-13868. Besies, groupmembersonly was removed in 2.8


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: