Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-25459

On first install, when creating admin user, received "Unsupported redirect detected" error

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0
    • Fix Version/s: None
    • Component/s: General
    • Environment:
      LAMP, Moodle 2.0 (Build: 20101129)
    • Affected Branches:
      MOODLE_20_STABLE

      Description

      Steps to reproduce:

      When installing Moodle 2 for the first time, when the screen prompting for the Admin user's details appears, I received an error when trying to upload a profile image.

      I click the "Choose a file..." button, the file chooser window appears. Almost immediately, a error dialogue pops up with the following text: "Unsupported redirect detected, script execution terminated".

      Further attempts to choose any of the options in the file options window end up with the same result.

      If I ignore these errors, complete the setup, and go back and edit my profile, the picture is uploaded successfully.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              skodak Petr Skoda added a comment -

              Hello,
              yes, this is a known problem on some systems. The problem is caused by attempt to detect PHP errors, unfortunately it fails when the error is hidden. I was already planning to spend more time on this.

              Thanks for the report.

              Petr Škoda

              skodak Petr Skoda added a comment -

              grrr, ignore my previous comment, it is a different problem.

              skodak Petr Skoda added a comment -

              Hello, this is fixed now, I have removed the option to set admin avatar and tags during the installation because it can not work yet there.

              Thanks for the report

              mcsquared Mark Cheverton added a comment - - edited

              Problem persists as of 10 Feb 2012.

              Using Mac OS X 10.6 with Moodle 2.2.1 and MAMP 2.0.5.

              tsala Helen Foster added a comment -

              Hi Mark,

              Sorry to hear that this bug remains unfixed. Thanks for creating MDL-31586, which I'm just linking to.


                People

                • Votes:
                  0 Vote for this issue
                  Watchers:
                  2 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: