Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-25473

Embedded MP4 videos via linking to the course file loops when finished playing.

    Details

    • Story Points (Obsolete):
      5
    • Sprint:
      FRONTEND Sprint 7

      Description

      When I embed a QuickTime video (MP4) like this:

      <a href="http://mymoodlesite.org/file.php/#/videos/Video_Title.mp4?d=800x450"></a> 
      

      It loops automatically when it is finished playing. This doesn't
      happen with FLV videos.

      I went into the Moodle folder
      -->filter
      ------>multimediaplugin
      ----------->Find every occurrence of the word loop (there were 4) and
      change true to false.
      Then I went back to where the video was embedded and added this tag
      before my embedded link:

      <param name="loop" value="false" /> 
      

      The video stopped after playing once.

        Gliffy Diagrams

          Activity

          Hide
          jonfila Jon Fila added a comment -

          I should add that the name of the file I edited was filter.php

          Show
          jonfila Jon Fila added a comment - I should add that the name of the file I edited was filter.php
          Hide
          salvetore Michael de Raadt added a comment -

          Thanks for reporting this issue.

          We have detected that this issue has been inactive for over a year has been recorded as affecting versions that are no longer supported.

          If you believe that this issue is still relevant to current versions (2.1 and beyond), please comment on the issue. Issues left inactive for a further month will be closed.

          Michael d;

          lqjjLKA0p6

          Show
          salvetore Michael de Raadt added a comment - Thanks for reporting this issue. We have detected that this issue has been inactive for over a year has been recorded as affecting versions that are no longer supported. If you believe that this issue is still relevant to current versions (2.1 and beyond), please comment on the issue. Issues left inactive for a further month will be closed. Michael d; lqjjLKA0p6
          Hide
          cfollin Chris Follin added a comment -

          Michael, we're having the same problem in 2.1.3.

          Show
          cfollin Chris Follin added a comment - Michael, we're having the same problem in 2.1.3.
          Hide
          patrickthibaudeau Patrick Thibaudeau added a comment -

          This problem affects all versions of 2.x including newly released 2.4. I would be more than happy to fix.

          Show
          patrickthibaudeau Patrick Thibaudeau added a comment - This problem affects all versions of 2.x including newly released 2.4. I would be more than happy to fix.
          Hide
          amy.call Amy Call added a comment -

          This issue also happens in version 2.3.

          Show
          amy.call Amy Call added a comment - This issue also happens in version 2.3.
          Hide
          cfollin Chris Follin added a comment -

          Updating affected versions to include 2.3 and 2.4.

          Patrick, if you can submit a git branch or patch, we'd appreciate it.

          Show
          cfollin Chris Follin added a comment - Updating affected versions to include 2.3 and 2.4. Patrick, if you can submit a git branch or patch, we'd appreciate it.
          Hide
          stronk7 Eloy Lafuente (stronk7) added a comment -

          This issue was assigned to me automatically, however I will not be able to work on this issue in the immediate future. In order to create a truer sense of the state of this issue and to allow other developers to have chance to become involved, I am removing myself as the assignee of this issue.

          For more information, see http://docs.moodle.org/dev/Changes_to_issue_assignment

          Show
          stronk7 Eloy Lafuente (stronk7) added a comment - This issue was assigned to me automatically, however I will not be able to work on this issue in the immediate future. In order to create a truer sense of the state of this issue and to allow other developers to have chance to become involved, I am removing myself as the assignee of this issue. For more information, see http://docs.moodle.org/dev/Changes_to_issue_assignment
          Hide
          phalacee Jason Fowler added a comment -

          I have grepped the code for all the current supported versions, and have been unable to find this in any of them. I am now looking at setting up the videos to test if it has been fixed.

          Show
          phalacee Jason Fowler added a comment - I have grepped the code for all the current supported versions, and have been unable to find this in any of them. I am now looking at setting up the videos to test if it has been fixed.
          Hide
          phalacee Jason Fowler added a comment -

          After testing, I found the code is no longer in the media filter plugin, but is now in the medialib file, so I am preparing a patch and test for this now.

          Show
          phalacee Jason Fowler added a comment - After testing, I found the code is no longer in the media filter plugin, but is now in the medialib file, so I am preparing a patch and test for this now.
          Hide
          abgreeve Adrian Greeve added a comment -

          [Y] Syntax
          [Y] Whitespace
          [Y] Output
          [-] Language
          [-] Databases
          [Y] Testing (instructions and automated tests)
          [-] Security
          [-] Documentation
          [Y] Git
          [-] Third party code
          [Y] Sanity check

          Thanks Jason, this looks all good.
          Submit for integration when ready.

          Show
          abgreeve Adrian Greeve added a comment - [Y] Syntax [Y] Whitespace [Y] Output [-] Language [-] Databases [Y] Testing (instructions and automated tests) [-] Security [-] Documentation [Y] Git [-] Third party code [Y] Sanity check Thanks Jason, this looks all good. Submit for integration when ready.
          Hide
          phalacee Jason Fowler added a comment -

          Thanks Adrian

          Show
          phalacee Jason Fowler added a comment - Thanks Adrian
          Hide
          samhemelryk Sam Hemelryk added a comment -

          Thanks Jason - this has been integrated now.

          Show
          samhemelryk Sam Hemelryk added a comment - Thanks Jason - this has been integrated now.
          Hide
          damyon Damyon Wiese added a comment -

          Test passed on all branches. (I had to use the conference room mac to test this)

          Show
          damyon Damyon Wiese added a comment - Test passed on all branches. (I had to use the conference room mac to test this)
          Hide
          damyon Damyon Wiese added a comment -

          Twas the week before Christmas,
          And all though HQ
          Devs were scrambling to finish peer review.
          They sent all their issues,
          and rushed out the door -
          "To the beach!" someone heard them roar!

          This issue has been released upstream. Thanks!

          Show
          damyon Damyon Wiese added a comment - Twas the week before Christmas, And all though HQ Devs were scrambling to finish peer review. They sent all their issues, and rushed out the door - "To the beach!" someone heard them roar! This issue has been released upstream. Thanks!

            People

            • Votes:
              11 Vote for this issue
              Watchers:
              11 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Fix Release Date:
                13/Jan/14

                Agile