Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-25489

File resource broken when uploading multiple files (why makes no sense but...)

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Not a bug
    • Affects Version/s: 2.0
    • Fix Version/s: None
    • Component/s: Resource
    • Labels:
      None
    • Affected Branches:
      MOODLE_20_STABLE

      Description

      For some reason that makes no sense (to me) you can upload multiple files into the File resource. However only one can be displayed. This is going to be really confusing to most users.

      Worse - the behaviour of the resource is different if you (e.g. I uploaded 2 text files)...
      1. Select the resource from the course page (the contents of the first file is simply displayed)
      2. Edit the resource and hit "save and display". A page is displayed with a link to (supposedly) the first resource but clicking seems to display some random resource from the course.

        Gliffy Diagrams

          Attachments

            Activity

            skodak Petr Skoda added a comment -

            1/ Sorry, but some people need to upload multiple files - flash with data files, html pages with linekd images, java apples with resources, etc.
            2/ The usability is far from optimal, but we did not find better solution yet. You need to select the "main" file if you upload mutiple files, that is the one displayed, if you do not select it moodle selects one for you automatically.
            3/ The action done after save depends on several settings and file type - it works fine for me. The problem here is we can not use back button in browser and popups, I doubt there is better way than displaying link on the next page.

            All these issues were discussed several times here in tracker, unfortunately handling of uploaded files will be always a bit confusing because there are some many different file types, crazy browsers and browser plugins and many settings in mod/resource itself.

            If you do not agree with me please file separate issues for each issue together with proposal how to solve the specific problem. Thanks for the report.

            Petr


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: