Moodle
  1. Moodle
  2. MDL-25498

Active tab showed over menu, breaking it

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0
    • Fix Version/s: 2.0.1
    • Component/s: Navigation
    • Labels:
      None
    • Affected Branches:
      MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE
    • Rank:
      1159

      Description

      Look at the screeshot attached and you'll get it.

        Issue Links

          Activity

          Hide
          Oleg Sychev added a comment -

          There was similar problem with help/active tab in standard theme, that seems to be fixed now.

          Show
          Oleg Sychev added a comment - There was similar problem with help/active tab in standard theme, that seems to be fixed now.
          Hide
          Helen Foster added a comment -

          Oleg, thanks for your report. Assigning to our moodle.org theme expert, Sam.

          Show
          Helen Foster added a comment - Oleg, thanks for your report. Assigning to our moodle.org theme expert, Sam.
          Hide
          Sam Hemelryk added a comment -

          Hi guys,

          Thanks for reporting the issue Oleg,
          I've just moved it to an MDL issue as I was able to reproduce it on my local site using the standard theme.
          The fix is simple, the YUI3 menu is using z-index = 1 which is good in that it is close to the content but not good because we've positioned alot of things and the natural z-index ends up being higher than that.
          The patch I've just attached sets the z-index to 500 which fixes the issue.

          Cheers
          Sam

          Show
          Sam Hemelryk added a comment - Hi guys, Thanks for reporting the issue Oleg, I've just moved it to an MDL issue as I was able to reproduce it on my local site using the standard theme. The fix is simple, the YUI3 menu is using z-index = 1 which is good in that it is close to the content but not good because we've positioned alot of things and the natural z-index ends up being higher than that. The patch I've just attached sets the z-index to 500 which fixes the issue. Cheers Sam
          Hide
          Petr Škoda added a comment -

          +1 for commit, thanks

          Show
          Petr Škoda added a comment - +1 for commit, thanks
          Hide
          Sam Hemelryk added a comment -

          Thanks for the review Petr, I've commit it now.

          Show
          Sam Hemelryk added a comment - Thanks for the review Petr, I've commit it now.

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: