Moodle
  1. Moodle
  2. MDL-25523

Random Allocation in Visible Groups mode does not work as expected

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0
    • Fix Version/s: 2.0.2
    • Component/s: Workshop
    • Labels:
      None
    • Affected Branches:
      MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE
    • Rank:
      6669

      Description

      When in Visible Groups mode, the default for modules in Moodle 2.0, Random Allocation does not behave as expected. If all the students in the Workshop are not in any groups, Random Allocation fails completely, stating that there are not enough peers, no matter how many markers are required in either direction.

      The problem is resolved by switching to No Groups mode, but as I said, this is not the default in Moodle 2.0, and teachers will probably not realise that this is the problem.

        Activity

        David Mudrak added a comment -

        Hi Morgan. Thanks for testing and reporting this. However, I do not agree.

        Firstly, Visible groups mode is not default for Moodle 2.0. Every site can define default values for new courses at Site administration > Courses > Course default settings. On a clean installation, the default value is No groups. Then, every course can set its own default mode and so can every activity (if the mode is not forced).

        Nevertheless, the random allocator is expected to allocate submissions to group members only if the workshop is in the Visible groups mode. This behaviour has been published and discussed at
        http://moodle.org/mod/forum/discuss.php?d=128473
        Shortly, the allocator tries to allocate the submissions so that the reviewers are from as many groups as possible. This can not work if there are no groups, of course. If the activity is in the Visible groups mode and there are no groups in the course, it is probably a mistake in the course content, rather than in the system itself.

        Please look at the linked thread, I hope it clarifies this.

        Morgan Harris added a comment -

        That's good, and sensible, and everything; it makes sense when you read it. However, it took me - on about a year of experience developing for, administering and using Moodle - almost an hour to figure out what the problem was. Now, I don't want to be rude, but users - including teachers - are idiots. Things that seem flat-out obvious to you and me can be completely invisible to them. After all, the course might be in Visible Groups mode - you're right, the default is No Groups, my mistake, but the point still stands - they may not realise it. I didn't. I didn't create the course I was testing in; someone else chose Visible Groups as the default mode for whatever reason. For teachers that don't use Groups a lot, the Group Mode option is totally opaque, they simply won't trace that as the root of the problem.

        So, this is essentially a silent fail. There's no bold "Some students were not allocated because they are not in groups ". There's absolutely nothing to tell the user why they are receiving this apparently aberrant behaviour. What's more, some users MIGHT be in groups, and other might not be, and the teacher could still have expected that everyone be allocated. If there's a lot of students, they're not going to notice until after some students email them saying they haven't got any papers to mark.

        Or, let's imagine a real horror story: the student logs in, sees that they have no papers to mark, and placidly accepts this. They don't imagine for a second that they're missing out on twenty percent of this assessment just because their teacher didn't notice some aberrant behaviour in their LMS. The teacher doesn't see it, the student accepts it - after all there's no error, just a notice - and they get a lower mark, or fail their course, because Moodle failed to inform them of the situation.

        Now this relies on both the teacher and all of their students not noticing this. But that's happened to us before, where each party thought the other knew what was happening. It's a big university, and a lot of stuff falls through the cracks.

        Basically, what I'm saying is: when a user clicks Random Allocation, they expect all their students to be allocated. If they're not, YOU NEED TO TELL THEM, or seriously bad shit can go down.

        David Mudrak added a comment -

        Resolving. The random allocation form now displays a warning if there are some users found who are not in any group in visible groups mode. Also, the procedure has been fixed so that no new reviews are allocated to these users, regardless they are authors or reviews (did not work well before).

        Helen Foster added a comment -

        Thanks Morgan and David. The fix for this issue will be included in the next 2.0.1+.


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: