Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-25570

Error when adding glossary entry and duplicates not allowed

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: 2.0
    • Fix Version/s: None
    • Component/s: Glossary
    • Labels:
      None
    • Database:
      MySQL
    • Affected Branches:
      MOODLE_20_STABLE

      Description

      Switch debugging on (not sure if this step is necessary)
      Create a new glossary
      Set duplicates to 'not allowed'
      Add an entry

      Error message: Field "LOWER(concept)" does not exist in table "glossary_entries"
      Stack trace:
      line 508 of /lib/dml/moodle_database.php: dml_exception thrown
      line 1207 of /lib/dml/moodle_database.php: call to moodle_database->where_clause()
      line 124 of /mod/glossary/edit_form.php: call to moodle_database->get_record()
      line 438 of /lib/formslib.php: call to mod_glossary_entry_form->validation()
      line 397 of /lib/formslib.php: call to moodleform->validate_defined_fields()
      line 484 of /lib/formslib.php: call to moodleform->is_validated()
      line 88 of /mod/glossary/edit.php: call to moodleform->get_data()

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              stronk7 Eloy Lafuente (stronk7) added a comment -

              Resolving this as duplicate of (already fixed) MDL-25418

              Thanks for the report, ciao

              dougiamas Martin Dougiamas added a comment -

              Duplicates should not have a fix version (it makes the release notes longer than they should be)

              stronk7 Eloy Lafuente (stronk7) added a comment -

              (agree, agree, I should be sleepy when I closed this - and others - as duplicates).

              Apologize and thanks!


                People

                • Votes:
                  0 Vote for this issue
                  Watchers:
                  0 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: