Moodle
  1. Moodle
  2. MDL-25656

Glossary: Linking of synonyms does not work correctly (searchstring cannot be found in the database-table "glossary_entries")

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 2.0
    • Fix Version/s: 2.0.1
    • Component/s: Glossary
    • Labels:
    • Affected Branches:
      MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE
    • Rank:
      15769

      Description

      It seems that the glossary-filter fails to link synonyms correctly to the corresponding glossary entry. I did not find any other ticket describing this issue, so I created this one. The use of Ajax is activated.

      Steps for reproducing the bug:
      1. Define a glossary entry "Geogebra-Plugin" and match whole words only and activate case sensitivity (we defined this options as default for our glossary)
      2. Define "Geogebra" as a synonym for the entry "Geogebra-Plugin".
      3. Now create another glossary entry or forum posting containing "Geogebra" as a phrase and "Geogebra-Plugin"
      4. Click on the phrase "Geogebra" and you will get an error, claiming the the search term cannot be found in the database table "glossary_entries", if you click on "Geogebra-Plugin" moodle returns the corresponding entry in an AJAX-popup.

      I did not test if the error also exists using the "non-ajax"-view, if you need a further report, let me know.

        Activity

        Helen Foster added a comment -

        Florian, thanks for reporting this issue. In order to help us fix it as quickly as possible, please could you turn debugging messages on for your site ( as explained in http://docs.moodle.org/en/Debugging ) then paste the message here.

        Florian Schneider added a comment -

        Hi Helen! Thank you for your fast answer. I turned on debugging on developer-level and got this debug info when trying to open the entry for "Geogebra" as described in the bug report:

        Debug info: SELECT * FROM

        {glossary_entries}

        WHERE id = ?
        [array (
        0 => 330,
        )]
        Stack trace:

        • line 1231 of /lib/dml/moodle_database.php: dml_missing_record_exception thrown
        • line 1208 of /lib/dml/moodle_database.php: call to moodle_database->get_record_select()
        • line 24 of /mod/glossary/showentry.php: call to moodle_database->get_record()

        As I got a couple of messages regarding the geogebra-filter in the header, I deactivated it, but as the problem existed before installing the geogebra-filter and also after deactivating it, it seems to be a general problem.

        We're running Moodle 2.0 (Build: 20101125) and we applied the patch for http://tracker.moodle.org/browse/MDL-25418. We enabled the TeX-Notation-Filter, the Geogebra-Filter (Contrib) and the Glossary-Linking-Filter.

        Florian Schneider added a comment -

        A small addition: It seems to affect the non-ajax and ajax-version of the glossary. In debug mode my browser tried to open the glossary entry not as a popup, but as a regular page and the error existed, too.

        Eloy Lafuente (stronk7) added a comment -

        Reproduced here, thanks for report and triaging... working on it now. Ciao

        Eloy Lafuente (stronk7) added a comment -

        The fix for this has been created and it's available @ https://github.com/stronk7/moodle/commit/bde23030d64c046fe20a43df60ed2830017f2f78

        It has been sent for review and, hopefully will be available next Moodle weekly build (follow PULL-9 evolution).

        Ciao

        Florian Schneider added a comment -

        Thank you for the quick fix!


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: