Moodle
  1. Moodle
  2. MDL-25694

Glossary: Autolink should include an disambiguation whenever multiple entries exist.

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 2.0
    • Fix Version/s: None
    • Component/s: Glossary
    • Labels:
    • Affected Branches:
      MOODLE_20_STABLE
    • Rank:
      15124

      Description

      The glossary module can be configured to allow multiple entries. This can be useful e.g. if you have a glossary for mathematics where should be distinguished between - for example - addition in analysis or geometry.

      So my idea would be to implement a disambiguation (for example like in wikipedia) based on categories. But here a step for step guide.

      • Create two categories "Analysis" and "Geometry" in your glossary
      • Add a new entry called "Addition" to your glossary (don't forget to activate site-wide autolinking), only search for full terms and the search should be case-sensitive. Add a sample text like "This explains addition in a analysis-context." and add the entry to the category "Analysis".
      • Add a second entry also called "Addition" with the same options like the other entry. Add a different sample text like "This explains addition in a geometry-context" and add this one to the category "Geometry".
      • Now create a forums post or a new glossary entry of your choice containing "Addition".

      What happens:

      • If you click on the "Addition"-Autolink in this post or glossary-entry, there opens a popup (if you have AJAX enabled) or a new page, containing the second (latest) entry with the name "Addition". Moodle simply ignores the first entry named "Addition".

      What should happen in my point of view:

      • If you click on the "Addition"-Autolink there should open a page or popup asking for the right entry in a "wikipedia-way". For example:

      ----------

      There are several entries for "Addition". Please choose the right one for you.
      Addition (Analysis)
      Addition (Geometry)

      ----------

      And of course the page should be offering links to all entries with the correct name.

      Thanks in advance, if you have further questions, feel free to ask!

        Issue Links

          Activity

          Eloy Lafuente (stronk7) added a comment -

          This issue was assigned to me automatically, however I will not be able to work on this issue in the immediate future. In order to create a truer sense of the state of this issue and to allow other developers to have chance to become involved, I am removing myself as the assignee of this issue.

          For more information, see http://docs.moodle.org/dev/Changes_to_issue_assignment

          Tim Hunt added a comment -

          This looks like a duplicate of MDL-9045


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: