Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-25750

Navigation block covers partly the activity report while using Overlay as theme

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 2.0
    • Fix Version/s: 2.0.2
    • Component/s: Themes
    • Labels:

      Description

      Using Softaculous I have installed Moodle 2.0 (Build: 20101125) on a subdomain of our DE site. I selected the Overlay theme. In the navigation block I clicked on courses > miscellaneous > Testing Moodle 2.0 (a test course) > reports > activity report.

        Gliffy Diagrams

          Activity

          stronk7 Eloy Lafuente (stronk7) added a comment -

          Moving this to the stable backlog and raising priority to critical.

          Thanks for the report, ciao

          samhemelryk Sam Hemelryk added a comment -

          Hi guys,

          I've just created a quick patch for this that gets the overlay report to produce a horizontal scrollbar when content attempts to go beyond the horizontal bounds of the content area.
          Unfortunately its not the best solution out there but to date I haven't been able to find a better layout for the themes with blocks on the right only.

          Could you please give this a once over Andrew?

          Cheers
          Sam

          samhemelryk Sam Hemelryk added a comment -

          Ahh sorry Andrew heres the link to the patch: https://github.com/samhemelryk/moodle/compare/master...wip-MDL-25750

          ptrkmkl Patrick Malley added a comment -

          Sam - shouldn't these changes be applied in the Base theme?

          samhemelryk Sam Hemelryk added a comment -

          Hi Patrick,

          The problem doesn't affect base theme as the report layout that gets used for these sorts of pages only has left side columns, for the base theme the solution was to set .region-content to overflow:visible for the report layout.
          For the theme's like overlay that have right hand side blocks only the solution is to set .region-content to overflow:auto for the report layout so that you at least get a scroll bar on the page.
          It's not an ideal solution because if the report has a large height it is easy to miss the scrollbar at the bottom and it is annoying to have so continually scroll down, then up again to scroll horizontally.
          Unfortunately however I've been unable to find a better solution for theme's with right hand side only blocks.

          Cheers
          Sam

          andyjdavis Andrew Davis added a comment -

          Sam, were you able to reproduce this? I cant get it to happen in FF, IE or Safari.

          Had a look through your changes. Its hard to isolate the actual changes youve made due to all the whitespace modifications you've made.

          samhemelryk Sam Hemelryk added a comment -

          Hi Andrew,

          The easiest way to reproduce this is to view the report using Firefox and then using firebug to set the style of the table to something seriously huge like 2000px.
          Alternatively the problem exists on all pages with huge content, all of which should use the report pagelayout so you could also track down other pages that use that layout to see if you can find the problem for real, I'd suggest other course reports or the grader report for that.

          Cheers
          Sam

          samhemelryk Sam Hemelryk added a comment -

          PULL-114 created for this issue

          tsala Helen Foster added a comment -

          Thanks everyone. The fix for this issue will be included in the next 2.0.1+.


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Fix Release Date:
                21/Feb/11