Moodle
  1. Moodle
  2. MDL-25760

Overlay theme sets the text of labels in a highlighted current topic section to white!

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 2.0
    • Fix Version/s: 2.0.6, 2.1.3
    • Component/s: Themes
    • Labels:
    • Rank:
      15227

      Description

      Overlay theme sets the text of labels in a highlighted current topic section to white!
      Fix: in moodle\theme\overlay\style\core.css file, locate:
      .course-content .current {
      background: #1f5480;
      color: #fff;
      }

      and remove the offending line

      color: #fff;

      see http://moodle.org/mod/forum/discuss.php?d=164693

      UPDATED - 22/10/2011

      I can confirm that the CSS for Overlay in Moodle 2.1.2(Build: 20111012) is still as it was prior to this fix being done.

      /* Course
      -------------------------------*/
      .course-content .main {
          border: 1px solid #eee;
          background: #eee;
      }
      
      .course-content .current {
          background: #1f5480;
          color: #fff;
      }
      
      .course-content .main .content {
          background: #fff;
      }
      

        Activity

        Hide
        Joseph Rézeau added a comment -

        Oops! other themes in the moodle regular distribution contain the same bug:
        binarius, boxxie, leatherbound, nonzero and serenity

        Show
        Joseph Rézeau added a comment - Oops! other themes in the moodle regular distribution contain the same bug: binarius, boxxie, leatherbound, nonzero and serenity
        Hide
        Martin Dougiamas added a comment -

        Patrick this seems to be a Canvas bug, can you please look at it?

        Show
        Martin Dougiamas added a comment - Patrick this seems to be a Canvas bug, can you please look at it?
        Hide
        Patrick Malley added a comment -

        Issue found and resolved in Boxxie, Binarius, Leatherbound, Nonzero, Serenity.

        Solution was to change the offending code to

        .course-content .current

        { background: #f14e16; }

        .course-content .current .left

        { color: #fff; }

        Pull request has been sent. Martin, out of curiosity, how should I handle tickets now - should I resolve the ticket after the pull request has been submitted? Or should I wait for it to be pulled in?

        Show
        Patrick Malley added a comment - Issue found and resolved in Boxxie, Binarius, Leatherbound, Nonzero, Serenity. Solution was to change the offending code to .course-content .current { background: #f14e16; } .course-content .current .left { color: #fff; } Pull request has been sent. Martin, out of curiosity, how should I handle tickets now - should I resolve the ticket after the pull request has been submitted? Or should I wait for it to be pulled in?
        Hide
        Petr Škoda added a comment -

        Please file the PULL request through this tracker instead, we are not processing the requests on jira at all. I am going to disable the issues and hopefully requests too there.

        Thanks.

        Show
        Petr Škoda added a comment - Please file the PULL request through this tracker instead, we are not processing the requests on jira at all. I am going to disable the issues and hopefully requests too there. Thanks.
        Hide
        Mary Evans added a comment -

        Just had a request in the Themes forum for the fix for this! Unresolved?

        Show
        Mary Evans added a comment - Just had a request in the Themes forum for the fix for this! Unresolved?
        Hide
        Helen Foster added a comment - - edited

        Hi Mary, this issue should be fixed in tomorrow's 2.0.2+ weekly.

        Show
        Helen Foster added a comment - - edited Hi Mary, this issue should be fixed in tomorrow's 2.0.2+ weekly.
        Hide
        Helen Foster added a comment -

        Confirming that the fix is available in the latest 2.0.2+ weekly. Thanks everyone.

        Show
        Helen Foster added a comment - Confirming that the fix is available in the latest 2.0.2+ weekly. Thanks everyone.
        Hide
        Mary Evans added a comment -

        Why was Overlay theme never fixed in this PULL as we are still getting reports about this same issue?

        Show
        Mary Evans added a comment - Why was Overlay theme never fixed in this PULL as we are still getting reports about this same issue?
        Hide
        Mary Evans added a comment -

        I'm re-opening this as the BUG was NOT fixed in the theme which this Tracker Issue was all about!

        Show
        Mary Evans added a comment - I'm re-opening this as the BUG was NOT fixed in the theme which this Tracker Issue was all about!
        Hide
        Sam Hemelryk added a comment -

        Thanks for picking that up Mary - this has been integrated now

        Show
        Sam Hemelryk added a comment - Thanks for picking that up Mary - this has been integrated now
        Hide
        Ankit Agarwal added a comment -

        This needs testing instructions

        Show
        Ankit Agarwal added a comment - This needs testing instructions
        Hide
        Michael de Raadt added a comment -

        Test result: Label text appeared correctly in the current topic. Checked across the themes mentioned in IE, FF and Chrome.

        Show
        Michael de Raadt added a comment - Test result: Label text appeared correctly in the current topic. Checked across the themes mentioned in IE, FF and Chrome.
        Hide
        Mary Evans added a comment -

        @Michael
        Thanks for testing this...sorry I was too late in getting here to add the instructions!

        Show
        Mary Evans added a comment - @Michael Thanks for testing this...sorry I was too late in getting here to add the instructions!
        Hide
        Eloy Lafuente (stronk7) added a comment -

        And this has been sent upstream (already available @ git and cvs repos). Many, many thanks!

        Closing as fixed, ciao

        Show
        Eloy Lafuente (stronk7) added a comment - And this has been sent upstream (already available @ git and cvs repos). Many, many thanks! Closing as fixed, ciao

          People

          • Votes:
            1 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: