Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-25813

LDAP Enrollment configuration that was working fails after upgrade to 2.0.1 from 2.0

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0.1
    • Fix Version/s: 2.0.2
    • Component/s: Enrolments
    • Labels:
      None
    • Environment:
      Windows 2008 R2 X64, IIS 7.5, PHP 5.3.3 NTS (X86). The server is running in a VM (hyper-v).
      The database is a local install of SQL Express 2008 R2.
    • Database:
      Microsoft SQL
    • Affected Branches:
      MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE

      Description

      Logging into the moodle site generates this error:

      Invalid $user parameter in sync_user_enrolments(), missing idnumber
      line 144 of \enrol\ldap\lib.php: call to debugging()
      line 217 of \lib\enrollib.php: call to enrol_ldap_plugin->sync_user_enrolments()
      line 882 of \lib\sessionlib.php: call to enrol_check_plugins()
      line 3809 of \lib\moodlelib.php: call to session_set_user()
      line 178 of \login\index.php: call to complete_user_login()
      Skip to main contentThis page should automatically redirect. If nothing is happening please use the continue link below.

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  21/Feb/11