Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-25840

Blog image attachments missing

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 2.0.1
    • Fix Version/s: 2.0.3
    • Component/s: Blog
    • Environment:
      LAMP

      Description

      After upgrading from 1.9.5+ to 2.0.1 build 20101229, the blog image attachments are gone. The .pdf attachments however, are there. The upgrade showed success everywhere.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              Hide
              123iitjee Manish Verma added a comment -

              I tested this on moodle.org blog by making a dummy blog post with image attachment and found the issue there also with the attached image display.

              Show
              123iitjee Manish Verma added a comment - I tested this on moodle.org blog by making a dummy blog post with image attachment and found the issue there also with the attached image display.
              Hide
              skodak Petr Skoda added a comment -

              Confirming, the image links are printed incorrectly, it is not a blocker because no data is lost.

              thanks for the report.

              Show
              skodak Petr Skoda added a comment - Confirming, the image links are printed incorrectly, it is not a blocker because no data is lost. thanks for the report.
              Hide
              123iitjee Manish Verma added a comment -

              Fine, I am not fully aware about bug categorisation definitions from developers' perspective. From user perspective, a fully functional production site shows images missing which looks pretty serious.

              Show
              123iitjee Manish Verma added a comment - Fine, I am not fully aware about bug categorisation definitions from developers' perspective. From user perspective, a fully functional production site shows images missing which looks pretty serious.
              Hide
              tsala Helen Foster added a comment -

              Manish, thanks for your report.

              It seems that blog attachments not displaying is also a problem in new 2.0.1+ sites, and not just upgraded sites, as reported in the discussion http://moodle.org/mod/forum/discuss.php?d=163398

              I agree with you that it's a serious problem and so am increasing the priority to critical.

              Show
              tsala Helen Foster added a comment - Manish, thanks for your report. It seems that blog attachments not displaying is also a problem in new 2.0.1+ sites, and not just upgraded sites, as reported in the discussion http://moodle.org/mod/forum/discuss.php?d=163398 I agree with you that it's a serious problem and so am increasing the priority to critical.
              Hide
              nebgor Aparup Banerjee added a comment -

              Hello,
              i'm having trouble replicating this.
              i tried 1.9.11 with blog images and file attachments upgrading to MOODLE_20_STABLE and the images and attachments display and download fine.

              Helen, in my 2.0.x install (non-upgraded), the blog attachments seem to show fine too.

              Show
              nebgor Aparup Banerjee added a comment - Hello, i'm having trouble replicating this. i tried 1.9.11 with blog images and file attachments upgrading to MOODLE_20_STABLE and the images and attachments display and download fine. Helen, in my 2.0.x install (non-upgraded), the blog attachments seem to show fine too.
              Hide
              nebgor Aparup Banerjee added a comment - - edited

              oh, i've got the bug (while attaching an image as a file, not inline), fixing..

              Show
              nebgor Aparup Banerjee added a comment - - edited oh, i've got the bug (while attaching an image as a file, not inline), fixing..
              Hide
              dongsheng Dongsheng Cai added a comment -

              Peer reviewed, +1

              Show
              dongsheng Dongsheng Cai added a comment - Peer reviewed, +1
              Hide
              nebgor Aparup Banerjee added a comment -

              thanks Dongsheng ! PULL-641 and PULL-642 created.

              Show
              nebgor Aparup Banerjee added a comment - thanks Dongsheng ! PULL-641 and PULL-642 created.
              Hide
              skodak Petr Skoda added a comment -

              Reopening because testing of PULL failed, sorry.

              Show
              skodak Petr Skoda added a comment - Reopening because testing of PULL failed, sorry.
              Hide
              nebgor Aparup Banerjee added a comment -

              um, i'd gathered that the link being broken was the issue ..

              do we want to display an attached file (that happens to be an image) as a file link to download
              or
              render it inline (as if it was actually attached inline) ?

              Show
              nebgor Aparup Banerjee added a comment - um, i'd gathered that the link being broken was the issue .. do we want to display an attached file (that happens to be an image) as a file link to download or render it inline (as if it was actually attached inline) ?
              Hide
              tsala Helen Foster added a comment -

              Apologies if I was wrong in failing the pull request. The patch did provide an attachment download link, however I failed it because I thought that for consistency, attached images should be treated the same as elsewhere in Moodle.

              Show
              tsala Helen Foster added a comment - Apologies if I was wrong in failing the pull request. The patch did provide an attachment download link, however I failed it because I thought that for consistency, attached images should be treated the same as elsewhere in Moodle.
              Hide
              nebgor Aparup Banerjee added a comment -

              Thanks Helen, yes apparently that is whats desired! (that was close!) , fixing.

              Show
              nebgor Aparup Banerjee added a comment - Thanks Helen, yes apparently that is whats desired! (that was close!) , fixing.
              Show
              nebgor Aparup Banerjee added a comment - ok, fixes up at https://github.com/nebgor/moodle/compare/mistress...MDL-25840 and https://github.com/nebgor/moodle/compare/mistress...MDL-25840_MOODLE_20_STABLE
              Hide
              dongsheng Dongsheng Cai added a comment -

              Peer reviewed, thanks.

              Show
              dongsheng Dongsheng Cai added a comment - Peer reviewed, thanks.
              Hide
              stronk7 Eloy Lafuente (stronk7) added a comment -

              Integrated, thanks!

              For any reason, I the 20_STABLE fix didn't apply clean (tons of conflicts), so I've cherry-picked it from master as far as solution was the same.

              I'd recommend to test this in both 20_STABLE and master to be 100% sure everything is ok.

              Ciao

              Show
              stronk7 Eloy Lafuente (stronk7) added a comment - Integrated, thanks! For any reason, I the 20_STABLE fix didn't apply clean (tons of conflicts), so I've cherry-picked it from master as far as solution was the same. I'd recommend to test this in both 20_STABLE and master to be 100% sure everything is ok. Ciao
              Hide
              tsala Helen Foster added a comment -

              Passing this test as images are now shown inline. I did notice however that the comments link is positioned incorrectly and reported it as MDL-27372.

              Show
              tsala Helen Foster added a comment - Passing this test as images are now shown inline. I did notice however that the comments link is positioned incorrectly and reported it as MDL-27372 .
              Hide
              stronk7 Eloy Lafuente (stronk7) added a comment -

              Closing as fixed. Many thanks!

              Show
              stronk7 Eloy Lafuente (stronk7) added a comment - Closing as fixed. Many thanks!

                People

                • Votes:
                  4 Vote for this issue
                  Watchers:
                  4 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    5/May/11