Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-25870

Enroll Search Results not displaying in Firefox 3.6.13

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 2.0.1
    • Fix Version/s: 2.0.4, 2.1.1
    • Component/s: Enrolments
    • Environment:
      Firefox Browser (for Mac): 3.6.13
    • Database:
      MySQL
    • Testing Instructions:
      1. Log in as an admin on a site with lots of users
      2. Browse to a course that doesn't have many enrolled users
      3. In settings goto: Course Administration > Users > Enrolled users
      4. In the drop down select manual and wait for the page to reload
      5. Click Enrol Users button
      6. Scroll to the bottom of the list of users
      7. Click Next 25...
      8. Verify that you now see the next 25 as well as the previous 25.
      9. In the search box type something that will result in less than 10 users being found.
      10. Press enter to search.
      11. Verify that you see the correct number of users.
      Show
      Log in as an admin on a site with lots of users Browse to a course that doesn't have many enrolled users In settings goto: Course Administration > Users > Enrolled users In the drop down select manual and wait for the page to reload Click Enrol Users button Scroll to the bottom of the list of users Click Next 25... Verify that you now see the next 25 as well as the previous 25. In the search box type something that will result in less than 10 users being found. Press enter to search. Verify that you see the correct number of users.
    • Affected Branches:
      MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE, MOODLE_21_STABLE
    • Pull Master Branch:
      wip-MDL-25870-master

      Description

      Enrolling users in a course brings up search box. Type in a name, partial name, partial email, etc. and enter return.

      In the Firefox browser tested, a count of results came back (eg. "2 users found"), but their individual records and the "enrol" button next to each record did NOT display. Results from the search do display in the Chrome browser correctly.

      See screenshots between Chrome's working functionality and Firefox's broken functionality attached.

        Gliffy Diagrams

        1. Mood20CHROME.tiff
          312 kB
          Bren Campbell
        2. Mood20FIREFOX.tiff
          217 kB
          Bren Campbell

          Activity

          bgcampbell Bren Campbell added a comment -

          Search results are now displaying correctly for me. Don't know whether this was a server-related/timeout issue or not, as I was on wireless when I experienced the issue.

          carolinemoore Caroline Moore added a comment -

          I'm getting a different sort of error: when I use the search box to find users to enroll, it "thinks," then simply displays the entire list of users as results. This makes it very difficult to find users to enroll, and would render the new enrollment interface completely unusable in a production environment with thousands of users.

          I'm getting this problem on a Mac running Firefox 3.0. I know this is a slightly old version of FF; could that be the cause of the problem? I'll try updating and see if it resolves the problem.

          It does work fine in Safari 5.0.1 on the Mac and IE 8 on Windows (and when it works, it looks great!).

          carolinemoore Caroline Moore added a comment -

          I upgraded to Firefox 3.6, and the search now works fine. Hooray!

          cfollin Chris Follin added a comment -

          We're having the same basic problem in 2.0.2 and 2.0.3 with just a few differences. First, the search results work correctly if searching for a user immediately after loading the enrol users popup box but if there are more than 25 enrollable users and we click "Next 25" then search for a user, we have the same problem where it says "1 user found" but no users are displayed. Also, we're having this issue in multiple browsers: Firefox 3, Firefox 4, Chrome 11, and Safari 5. I'm not sure about IE.

          Steps to reproduce. There must be more than 25 enrollable users in order to see the Next 25 link.

          1. Login as an admin (or instructor, possibly) to a 2.0.2 or 2.0.3 site
          2. Go to any course
          3. Go to the Settings block
          a. Click Users
          b. Click Enrolled Users
          c. Choose Manual enrollments from drop down box
          d. Click Enrol Users
          4. Enrollment window opens
          a. Scroll down to the bottom
          b. Click "Next 25..."
          c. In the search box enter a name that should be found
          d. Box states X users found, but users are not populated into the window to select for enrollment

          • Expected result

          Window populates with found users when searching for a user after clicking "Next 25..."

          • Actual result

          Window searches and finds users, but doesn't populate window with users to select for enrollment

          mblake Michael Blake added a comment -

          This issue is reported as causing problems for a MP client. Please give it priority.

          samhemelryk Sam Hemelryk added a comment -

          Fixed now, peer review please - the page of users being requested wasn't being reset when a new search was being run.

          nebgor Aparup Banerjee added a comment -

          Sam,
          I've just looked at this and it has fixed the problem for me, i can see my search results!
          cheers!

          samhemelryk Sam Hemelryk added a comment -

          Cool thanks for looking at that Apu, this has now been put up for integration!

          Cheers
          Sam

          skodak Petr Skoda added a comment -

          Integrated, thanks.

          skodak Petr Skoda added a comment -

          Tested, works as described.


            People

            • Votes:
              9 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Fix Release Date:
                1/Aug/11