Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-25884

quiz listing url (at least on demo site) yields "Coding error detected, it must be fixed by a programmer: PHP catchable fatal error"

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.0.1
    • Fix Version/s: 2.0.2
    • Component/s: Quiz
    • Labels:
      None
    • Environment:
    • Affected Branches:
      MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE

      Description

      Steps:

      1. Log in (this doesn't happen as 'guest')
      2. Please try URL for listing all quizzes

      http://demo.moodle.net/mod/quiz/index.php?id=596

      to see "Coding error detected, it must be fixed by a programmer: PHP catchable fatal error"

      Expecting:
      a list of all quizzes for this course, as v1.9 supplies.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              timhunt Tim Hunt added a comment -

              I can't reproduce this. I went there and logged in a teacher, and it just worked.

              timhunt Tim Hunt added a comment -

              Ah, but it is reproducible if you log in as a Student.

              tsala Helen Foster added a comment -

              Fred, thanks for reporting this issue, and Tim, thanks for fixing it. The fix will be included in the next weekly Moodle 2.0.1+.


                People

                • Votes:
                  0 Vote for this issue
                  Watchers:
                  1 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    21/Feb/11