Moodle
  1. Moodle
  2. MDL-25885

Prevent autolink filter not working in 2.0 quiz

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 2.0
    • Fix Version/s: None
    • Component/s: Questions, Quiz
    • Labels:
    • Environment:
      Moodle 2.0.1 (Build: 20101225), php5.3
    • Affected Branches:
      MOODLE_20_STABLE

      Description

      Ref mod/forum/discuss.php?d=165538
      I created a quiz exactly as normal, then previewed it and realised that the answers in the quiz had been autolinked to my main glossary. I went into activity filters and chose autolink-off. I cleared the caches and my browser cache then went back to the quiz. Autolinking was still active. I did nothing unusual in creating the quiz. Obviously, this renders it very difficult to create quizzes if they involve testing on concepts added to the glossary.
      This defective filter wouldn't be so important if it were possible to use prevent autolinking (at individual question level) on the quiz answers (it can be selected on questions, not answers).

        Gliffy Diagrams

          Issue Links

            Activity

            Brian Avery created issue -
            Joseph Rézeau made changes -
            Field Original Value New Value
            Link This issue has a non-specific relationship to MDL-24996 [ MDL-24996 ]
            Tim Hunt added a comment -

            Following on from the discussion in MDL-24996, what needs to be done is to review every call to format_text in mod/quiz and question, and make sure $options->context is always passed. That sounds like fun

            Actually, I just did a quick search, and there are only 40 calls to review. That could be a lot worse.

            Tim Hunt made changes -
            Labels triaged
            Fix Version/s STABLE backlog [ 10463 ]
            Priority Minor [ 4 ] Major [ 3 ]
            Component/s Questions [ 10087 ]
            Martin Dougiamas made changes -
            Workflow MDL Workflow [ 66664 ] MDL Full Workflow [ 75603 ]
            Joseph Rézeau added a comment -

            Bug fixed in 2.1, but still not fixed in 2.0.

            Tim Hunt added a comment -

            Joseph's last comment says this is no longer a problem in 2.1+. 2.0 is no longer supported, so closing this.

            Tim Hunt made changes -
            Status Open [ 1 ] Closed [ 6 ]
            Fix Version/s STABLE backlog [ 10463 ]
            Resolution Cannot Reproduce [ 5 ]

              People

              • Votes:
                4 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: