Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-25909

Undefined variable when using q&a forum - and student can't yet see post

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Trivial
    • Resolution: Fixed
    • Affects Version/s: 2.0.1
    • Fix Version/s: 2.0.2
    • Component/s: Forum
    • Labels:
      None
    • Difficulty:
      Easy
    • Affected Branches:
      MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE

      Description

      Steps to reproduce:

      1) Create a q&a forum and post a question & a response
      2) Login as a student and view the q&a forum

      There will then be a notice displayed (in developer mode):
      Notice: Undefined variable: forumpostclass in /home/danp/git/moodle/mod/forum/lib.php on line 3158

      This is because the forum_print_post function uses $forumpostclass before it is defined later in the function.

        Gliffy Diagrams

          Attachments

            Activity

            poltawski Dan Poltawski added a comment -

            PULL-85 Created


              People

              • Assignee:
                poltawski Dan Poltawski
                Reporter:
                poltawski Dan Poltawski
                Participants:
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  21/Feb/11