Moodle
  1. Moodle
  2. MDL-26016

The Lesson progress bar does not appear

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.0, 2.2.1
    • Fix Version/s: None
    • Component/s: Lesson
    • Labels:
    • Affected Branches:
      MOODLE_20_STABLE, MOODLE_22_STABLE

      Description

      I've enabled the Progress Bar in Lesson settings, but nothing shows when I sign in as a student (verified by several others who are students). I believe it's not just me – a few others have reported the same problem in the Forum. Would appreciate your help! Thank you.

        Gliffy Diagrams

          Issue Links

            Activity

            Hide
            Daren Chandisingh added a comment -

            I haven't mamaged to reproduce this yet. Are you using the default theme? Which browser is it?

            Show
            Daren Chandisingh added a comment - I haven't mamaged to reproduce this yet. Are you using the default theme? Which browser is it?
            Hide
            Jason Ilicic added a comment -

            It looks like this is a theme issue. Ensure you include the progress_bar classes in your custom theme.

            Show
            Jason Ilicic added a comment - It looks like this is a theme issue. Ensure you include the progress_bar classes in your custom theme.
            Hide
            Mark Nelson added a comment -

            Hi Jason, I would just like to point out that this issue occurs in the Moodle standard themes as well, so I doubt it is a theming issue unless these CSS classes were excluded by accident.

            Show
            Mark Nelson added a comment - Hi Jason, I would just like to point out that this issue occurs in the Moodle standard themes as well, so I doubt it is a theming issue unless these CSS classes were excluded by accident.
            Hide
            Shane Elliott added a comment -

            Bump. Just wondering if there is any update on this?

            Show
            Shane Elliott added a comment - Bump. Just wondering if there is any update on this?
            Hide
            Mary Cooch added a comment -

            I was going to take a screenshot of this to document it and came across these tracker entries. On the demo Moodle site with standard theme I just get a green box - on a 2.2 site with Boxy theme I don't actually see any progress bar but I do see the green box when I switch to Standard. So is it a theme issue as mentioned above? And is this the correct appearance of the progress bar?

            Show
            Mary Cooch added a comment - I was going to take a screenshot of this to document it and came across these tracker entries. On the demo Moodle site with standard theme I just get a green box - on a 2.2 site with Boxy theme I don't actually see any progress bar but I do see the green box when I switch to Standard. So is it a theme issue as mentioned above? And is this the correct appearance of the progress bar?
            Hide
            Rossiani Wijaya added a comment -

            It looks like the progress bar is missing a background color in css file.

            However, this issue should be fixed through MDL-30910, which is available on this weekly release.

            Please let me know if this issues still occurs.

            Note: please try to purge all caches if you still can't view the progress bar after updating your Moodle site.

            Show
            Rossiani Wijaya added a comment - It looks like the progress bar is missing a background color in css file. However, this issue should be fixed through MDL-30910 , which is available on this weekly release. Please let me know if this issues still occurs. Note: please try to purge all caches if you still can't view the progress bar after updating your Moodle site.
            Hide
            Rossiani Wijaya added a comment -

            This issue has been fixed through MDL-30910. Please create new issue if the issue is still exist.

            Thanks

            Closing.

            Show
            Rossiani Wijaya added a comment - This issue has been fixed through MDL-30910 . Please create new issue if the issue is still exist. Thanks Closing.

              People

              • Votes:
                3 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: