Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-26016

The Lesson progress bar does not appear

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.0, 2.2.1
    • Fix Version/s: None
    • Component/s: Lesson
    • Labels:
    • Affected Branches:
      MOODLE_20_STABLE, MOODLE_22_STABLE

      Description

      I've enabled the Progress Bar in Lesson settings, but nothing shows when I sign in as a student (verified by several others who are students). I believe it's not just me – a few others have reported the same problem in the Forum. Would appreciate your help! Thank you.

        Gliffy Diagrams

          Issue Links

            Activity

            kjwelds@gmail.com Karen Welds created issue -
            Hide
            darenc Daren Chandisingh added a comment -

            I haven't mamaged to reproduce this yet. Are you using the default theme? Which browser is it?

            Show
            darenc Daren Chandisingh added a comment - I haven't mamaged to reproduce this yet. Are you using the default theme? Which browser is it?
            dougiamas Martin Dougiamas made changes -
            Field Original Value New Value
            Workflow MDL Workflow [ 66889 ] MDL Full Workflow [ 75680 ]
            Hide
            jaseeey Jason Ilicic added a comment -

            It looks like this is a theme issue. Ensure you include the progress_bar classes in your custom theme.

            Show
            jaseeey Jason Ilicic added a comment - It looks like this is a theme issue. Ensure you include the progress_bar classes in your custom theme.
            salvetore Michael de Raadt made changes -
            Link This issue is duplicated by MDL-29300 [ MDL-29300 ]
            Hide
            markn Mark Nelson added a comment -

            Hi Jason, I would just like to point out that this issue occurs in the Moodle standard themes as well, so I doubt it is a theming issue unless these CSS classes were excluded by accident.

            Show
            markn Mark Nelson added a comment - Hi Jason, I would just like to point out that this issue occurs in the Moodle standard themes as well, so I doubt it is a theming issue unless these CSS classes were excluded by accident.
            ikawhero Shane Elliott made changes -
            Labels partner
            Hide
            ikawhero Shane Elliott added a comment -

            Bump. Just wondering if there is any update on this?

            Show
            ikawhero Shane Elliott added a comment - Bump. Just wondering if there is any update on this?
            Hide
            marycooch Mary Cooch added a comment -

            I was going to take a screenshot of this to document it and came across these tracker entries. On the demo Moodle site with standard theme I just get a green box - on a 2.2 site with Boxy theme I don't actually see any progress bar but I do see the green box when I switch to Standard. So is it a theme issue as mentioned above? And is this the correct appearance of the progress bar?

            Show
            marycooch Mary Cooch added a comment - I was going to take a screenshot of this to document it and came across these tracker entries. On the demo Moodle site with standard theme I just get a green box - on a 2.2 site with Boxy theme I don't actually see any progress bar but I do see the green box when I switch to Standard. So is it a theme issue as mentioned above? And is this the correct appearance of the progress bar?
            tsala Helen Foster made changes -
            Link This issue has a non-specific relationship to MDL-30910 [ MDL-30910 ]
            tsala Helen Foster made changes -
            Priority Minor [ 4 ] Major [ 3 ]
            Labels partner partner triaged
            Affects Version/s 2.2.1 [ 11456 ]
            tsala Helen Foster made changes -
            Fix Version/s STABLE backlog [ 10463 ]
            Hide
            rwijaya Rossiani Wijaya added a comment -

            It looks like the progress bar is missing a background color in css file.

            However, this issue should be fixed through MDL-30910, which is available on this weekly release.

            Please let me know if this issues still occurs.

            Note: please try to purge all caches if you still can't view the progress bar after updating your Moodle site.

            Show
            rwijaya Rossiani Wijaya added a comment - It looks like the progress bar is missing a background color in css file. However, this issue should be fixed through MDL-30910 , which is available on this weekly release. Please let me know if this issues still occurs. Note: please try to purge all caches if you still can't view the progress bar after updating your Moodle site.
            rwijaya Rossiani Wijaya made changes -
            Assignee moodle.com [ moodle.com ] Rossiani Wijaya [ rwijaya ]
            rwijaya Rossiani Wijaya made changes -
            Fix Version/s STABLE Sprint 19 [ 11951 ]
            Fix Version/s STABLE backlog [ 10463 ]
            Hide
            rwijaya Rossiani Wijaya added a comment -

            This issue has been fixed through MDL-30910. Please create new issue if the issue is still exist.

            Thanks

            Closing.

            Show
            rwijaya Rossiani Wijaya added a comment - This issue has been fixed through MDL-30910 . Please create new issue if the issue is still exist. Thanks Closing.
            rwijaya Rossiani Wijaya made changes -
            Status Open [ 1 ] Closed [ 6 ]
            Resolution Fixed [ 1 ]
            stronk7 Eloy Lafuente (stronk7) made changes -
            Fix Version/s STABLE Sprint 19 [ 11951 ]

              People

              • Votes:
                3 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: