Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-26042

Coding error paging bar requires a per page value

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Cannot Reproduce
    • Affects Version/s: 2.0, 2.0.1, 2.2
    • Fix Version/s: STABLE backlog
    • Component/s: Administration, General
    • Labels:
    • Environment:
      Windows Server 2003 using a BITNAMI install.
    • Database:
      MySQL
    • Testing Instructions:

      1/ Go to Admin > Frontpage > Front page settings
      2/ Set courses per page and set value to 0
      3/ Visit Admin > Courses > Add edit courses
      4/ Select a category

      Expected reuslt:
      courses returned

      Actual result:
      coding error

      Show
      1/ Go to Admin > Frontpage > Front page settings 2/ Set courses per page and set value to 0 3/ Visit Admin > Courses > Add edit courses 4/ Select a category Expected reuslt: courses returned Actual result: coding error
    • Affected Branches:
      MOODLE_20_STABLE, MOODLE_22_STABLE

      Description

      I have a test install of Moodle 2.01+using the Base theme.

      I've just started creating a test set up but have come up with the following error whilst creating categories.

      The attached error message only shows in Internet Explorer and won't let me progress to a course that I've created under the last category of the screen shot - works OK in Firefox, Chrome and Opera.

      My initial test site install was using Moodle 2.0 when I came across this issue. Only changes I'd made was to the Theme "Splash" by adding the path to a graphic for a logo plus added some entries for the top drop down menu.
      I then upgraded to 2.01+ and still had the error as detailed.
      What I did notice after the upgrade was that the theme Spash seemed to have lost it's formatting even after a cache clear.
      So I changed to Base theme to explore from there.
      Interestingly I was able to navigate to my test course using IE 8 via the Navigation menu in the side bar OK
      Rob

        Gliffy Diagrams

          Issue Links

            Activity

            screamadelica Julia added a comment -

            I have the same problem. I have two course categories ("Miscelanea" and "Inglés"), when I click on Site administration -> Courses ->Add/edit courses, my categories are listed, and when I click on "Inglés", this message appears.

            I have the standard theme and I work only with firefox.

            Version: 2.0.1+ (Windows, Xampp...)
            Database: postgreSql

            tracey Tracey Manley added a comment -

            I am running Moodle 2.0.2 on Ubuntu 8.04 and have had this problem with the following entry in the apache error log

            Default exception handler: Coding error detected, it must be fixed by a programmer: paging_bar requires a perpage value. Debug: \n* line 1935 of /lib/outputcomponents.php: coding_exception thrown\n* line 2194 of /lib/outputrenderers.php: call to paging_bar->prepare()\n* line 70 of /lib/outputrenderers.php: call to core_renderer->render_paging_bar()\n* line 2183 of /lib/outputrenderers.php: call to renderer_base->render()\n* line 261 of /course/category.php: call to core_renderer->paging_bar()\n

            I found a forum entry which said it was due to the front page settings having a coursesperpage of 0, I have checked and another admin had just changed the value to zero before the errors started appearing. I have changed it back to 20.

            Should an admin be allowed to change the value to zero if it breaks Moodle?

            jbach1203 Jayne Bachelor added a comment -

            Thanks Tracey, I had the same problem and changing the course per page setting back to 20 fixed it.

            llywmog llywelyn morgan added a comment -

            just had the same problem as julia when clicking on course category in moodle 2.3

            johanr Johan Reinalda added a comment -

            Same here, in 2.3.2 ...
            While not showing course on Frontpage, if courses per page = 0, error occurs...

            paul1965 Paul Vivian added a comment - - edited

            I have the same issue on one of my Moodle 2.5.1+ systems.

            Have done everything that people have said about the course numbers on front page settings and nothing happens. Another post https://moodle.org/mod/forum/discuss.php?d=163731

            Nothing. The admin of the system is getting rather annoyed as they can not do an thing.. Add or edit.

            Just a note, the new version of Moodle does not have the ability to adjust number of courses on page.

            andyjdavis Andrew Davis added a comment - - edited

            Hello. I'm closing this issue as it appears to have been fixed at some point (most likely by MDL-27824). I tested both the upcoming 2.7 and 2.5.5 and was not able to reproduce it.


              People

              • Votes:
                5 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: