Moodle
  1. Moodle
  2. MDL-26076

The Dock YUI menu is not scrolled properly

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 2.0, 2.0.1, 2.0.2
    • Fix Version/s: None
    • Component/s: Themes
    • Labels:
      None
    • Environment:
      On IE7, IE8 maybe IE6.
    • Difficulty:
      Easy
    • Affected Branches:
      MOODLE_20_STABLE
    • Rank:
      15634

      Description

      On IE, when we dock a block to the left, when all the item menu are open and the content is taller than the screen (a scroll bar appear), when we scroll, some items are fixed on the screen, some other, not.

        Activity

        Hide
        Jason Ilicic added a comment -

        It looks like there's a positioning issue on the items with icons in the base theme as I had this issue with my custom theme and could replicate in the core themes. I added the following into my CSS file and it looks like it's fixed:

        .item_with_icon .tree_item

        { position: static !important; }

        .tree_item .smallicon

        { position: static !important; margin-left: -18px !important; }
        Show
        Jason Ilicic added a comment - It looks like there's a positioning issue on the items with icons in the base theme as I had this issue with my custom theme and could replicate in the core themes. I added the following into my CSS file and it looks like it's fixed: .item_with_icon .tree_item { position: static !important; } .tree_item .smallicon { position: static !important; margin-left: -18px !important; }
        Hide
        Annick Fructoso added a comment -

        We also have this 'Major' bug in IE and this little script didn't fix it for us...
        Any more ideas? - Thanks.
        Annick

        Show
        Annick Fructoso added a comment - We also have this 'Major' bug in IE and this little script didn't fix it for us... Any more ideas? - Thanks. Annick
        Hide
        Mary Evans added a comment -

        Which version of Moodle are you using Annik?

        Show
        Mary Evans added a comment - Which version of Moodle are you using Annik?
        Hide
        Annick Fructoso added a comment -

        We have 2.3.1 and 2.2.2 installed and this is happening on both version.....
        Thanks

        Show
        Annick Fructoso added a comment - We have 2.3.1 and 2.2.2 installed and this is happening on both version..... Thanks
        Hide
        Annick Fructoso added a comment -

        Oh and this is happening on IE8 and IE9.

        Show
        Annick Fructoso added a comment - Oh and this is happening on IE8 and IE9.
        Hide
        Sambg added a comment -

        We have 2.3 with afterburner.
        I've tried your code Jason and it seems to have done the trick here on IE8.
        Seems adding these two lines to moodle core would be a good idea.

        Cheers, Sam.

        Show
        Sambg added a comment - We have 2.3 with afterburner. I've tried your code Jason and it seems to have done the trick here on IE8. Seems adding these two lines to moodle core would be a good idea. Cheers, Sam.

          People

          • Votes:
            4 Vote for this issue
            Watchers:
            6 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: