Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-26145

User to User talk feature in chat room does not work.

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.0.1, 2.2, 2.3
    • Fix Version/s: 2.2.5, 2.3.2
    • Component/s: Chat
    • Environment:
      RHEL 5.4, PHP 5.2.10, MySQL 5.0.77, Moodle 2.0.1 build 20101225
    • Database:
      MySQL
    • Testing Instructions:

      1.- Add a chat activity
      2.- Log in as an user (user1) with access to the activity and enter the chat
      3.- Log in as another user (user2) with access to the activity and enter the chat
      4.- Click the 'Talk' link, there SHOULD appear 'To user1:' in the text box

      Show
      1.- Add a chat activity 2.- Log in as an user (user1) with access to the activity and enter the chat 3.- Log in as another user (user2) with access to the activity and enter the chat 4.- Click the 'Talk' link, there SHOULD appear 'To user1:' in the text box
    • Workaround:

      Solution tested in Chrome, Firefox and IE8.

      Show
      Solution tested in Chrome, Firefox and IE8.
    • Difficulty:
      Easy
    • Affected Branches:
      MOODLE_20_STABLE, MOODLE_22_STABLE, MOODLE_23_STABLE
    • Fixed Branches:
      MOODLE_22_STABLE, MOODLE_23_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      MDL-26145_master

      Description

      user to user Talk feature in the Chat room area does not work.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              tsala Helen Foster added a comment -

              Hi Scott,

              I've never heard of a user to user talk feature in the chat module! Please could you explain how you think it's supposed to work. I did come across another chat issue - MDL-26094 - which seemed to suggest that prefixing a message with 'To' resulted in messages being sent to specific users. Perhaps this is what you are referring to?

              scottmcm Scott McMillan added a comment -

              included an attachment... the beep works. talk does nothing for me.

              dongsheng Dongsheng Cai added a comment -

              Thanks Scott and Helen

              This is a bug, Scott what browser are you using?

              Regards,
              Dongsheng Cai

              tsala Helen Foster added a comment -

              Scott, thanks for the screenshot. However, I don't understand why I don't see a talk link - see my attached screenshot.

              cfulton Charles Fulton added a comment -

              Helen: that looks like an old version of the chat module that you're using; I thought the js chat was dropped in 2.0. Scott's screenshot is from the ajax interface. I can confirm that nothing seems to happen when clicking "Talk" in both Firefox and Chrome. My dev server is running Moodle 2.0.1+ (Build: 20101229) on Apache/mySQL.

              dotsond Debra Dotson added a comment -

              I'm having the same problem when testing with IE8 and Firefox - 'Beep' works fine but nothing seems to happen when clicking 'Talk'.

              scottmcm Scott McMillan added a comment -

              Dongsheng,
              was using Safari 4.0.5, FF 3.6.11, Chrome 10.0.648.6

              jmlsteele Jody Steele added a comment - - edited

              This is caused by the   on line 250

              250:     var talk = Y.Node.create('<a href="###">'+M.str.chat.talk+'</a>&nbsp;');

              Remove the &nbsp; from there and add it later on (line 254) and everything will work properly.

              254:     li.all('td').item(1).append(Y.Node.create('<div></div>').append(talk).append('&nbsp;').append(beep));

              Tested on Firefox, and Chrome.

              Edit: I guess I should say which FILE. mod/chat/ajax_gui/module.js

              dmonllao David Monllaó added a comment -

              Thanks for the patch Jody. Adding pull branches

              fred Frédéric Massart added a comment -

              Patch looks good David. Feel free to push for integration when you're ready!

              poltawski Dan Poltawski added a comment -

              The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

              TIA and ciao

              samhemelryk Sam Hemelryk added a comment -

              Thanks David spot on again. Has been integrated now.

              rwijaya Rossiani Wijaya added a comment -

              This looks good.

              Test passed.

              poltawski Dan Poltawski added a comment -

              *Notice*: Undefined variable: friendlyintegrator in /Users/danp/git/tokenintegrationthanks.php on line 26

              Congratulations

              {tracker.user.name}

              !

              You've made into Moodle

              {tracker.fixversion-1}

              +

              I would like to personally thank you for this contribution on behalf of all Moodle users throughout the world.

              cheers!

              {tracker.friendlyintegrator}

                People

                • Votes:
                  2 Vote for this issue
                  Watchers:
                  5 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    10/Sep/12