Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-26172

upgrading Moodle 1.9.10+ to 2.0.1 ends up with files related issues

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.0.1
    • Fix Version/s: 2.0.2
    • Component/s: Installation
    • Environment:
      Windows 7 Prof / SQL Server 2008, PHP 5.3.5, Mysql 5.1.53-community, IIS 7.5
    • Difficulty:
      Moderate
    • Affected Branches:
      MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE

      Description

      I've got a problem with upgrading Moodle 1.9.10+ (Build: 20110119) to Moodle 2.0.1.
      My Moodle instalation is based on windows environment (PHP 5.3.5 and Mysql 5.1.53-community, IIS 7.5).
      During the upgrade I get the following exception:

      =======================================================
      Unknown exception related to local files (Invalid contextid)

      Stack trace:

      line 724 of \lib\filestorage\file_storage.php: file_exception thrown
      line 267 of \lib\db\upgradelib.php: call to file_storage->create_file_from_pathname()
      line 4764 of \lib\db\upgrade.php: call to upgrade_migrate_group_icons()
      line 1360 of \lib\upgradelib.php: call to xmldb_main_upgrade()
      line 252 of \admin\index.php: call to upgrade_core()
      =======================================================

      As I commented out the line which throws the exception,
      another exception was fired, but this time it has more meaningful content:

      =======================================================
      Can not create file "/group/icon/56///f1.jpg"
      Stack trace:

      line 793 of \lib\filestorage\file_storage.php: stored_file_creation_exception thrown
      line 267 of \lib\db\upgradelib.php: call to file_storage->create_file_from_pathname()
      line 4764 of \lib\db\upgrade.php: call to upgrade_migrate_group_icons()
      line 1360 of \lib\upgradelib.php: call to xmldb_main_upgrade()
      line 252 of \admin\index.php: call to upgrade_core()
      =======================================================

      please, check out the file name above - it is clearly wrong.

        Gliffy Diagrams

          Attachments

            Activity

            tsala Helen Foster added a comment -

            Lucas, thanks for your report. Setting a fix version of STABLE backlog and hoping the issue can be investigated soon.

            skodak Petr Skoda added a comment -

            Hello,
            this is most probably caused by invalid records in the group table, I am going to add a detection code and skip the records. Unfortunately you may encounter problems later, please file a new issue if necessary.

            Petr

            lucas7bd Łukasz Czyżewski added a comment -

            Great news!

            Thanks a lot!

            I will check it as soon as I can...

            Lucas.


              People

              • Votes:
                1 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  21/Feb/11