Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-26228

Grade full view cuts off viewable area

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 2.0.1
    • Fix Version/s: 2.0.3
    • Component/s: Gradebook
    • Labels:
    • Environment:
      php 5.2.10 . RHEL 5.4
    • Database:
      MySQL
    • Difficulty:
      Easy
    • Affected Branches:
      MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE

      Description

      When looking at the grade book in Full view the columns are cut when viewing in smaller browser windows.

      Solution add overflow:auto to Line 18 of theme/base/style/grade.css
      .gradetreebox

      {margin-top:10px; overflow:auto; }

        Gliffy Diagrams

          Attachments

            Activity

            andyjdavis Andrew Davis added a comment -

            There was similar css already there but it was in the standard theme rather than the base theme. Ive moved it into base.

            repo: git://github.com/andyjdavis/moodle.git
            branch: MDL-26228_grade_full_view
            diff: https://github.com/andyjdavis/moodle/compare/master...MDL-26228_grade_full_view

            andyjdavis Andrew Davis added a comment -

            PULL-364

            skodak Petr Skoda added a comment -

            Reopening because there was no feedback for the failed test in PULL request.

            andyjdavis Andrew Davis added a comment -

            Responded in PULL-364. Ive now raised PULL-372.

            skodak Petr Skoda added a comment -

            Reopening due to bogus author in git commit, sorry.

            andyjdavis Andrew Davis added a comment -

            PULL-399

            stronk7 Eloy Lafuente (stronk7) added a comment - - edited

            Related to this, always I see those reports under standard... I think current 70% is waste of space. So I would do something like:

            diff --git a/theme/standard/style/grade.css b/theme/standard/style/grade.css
            index 1f9c2df..81579f4 100644
            --- a/theme/standard/style/grade.css
            +++ b/theme/standard/style/grade.css
            @@ -18,12 +18,11 @@ td.grade div.overridden {background-color: #DDDDDD;}
             .path-grade-report-grader .graderreportoverlay {background-color:#EEEEEE;border:1px solid black;padding:10px;}
             
             .path-grade-edit-tree .moving {background-color: #E8EEF7;}
            -.path-grade-edit-tree .gradetreebox {width:70%;padding-bottom:15px;overflow-x:auto;overflow-y:hidden;}
            +.path-grade-edit-tree .gradetreebox {padding-bottom:15px;overflow-x:auto;overflow-y:hidden;}
             
             .path-grade-edit-scale .scale_options,
             #page-admin-grade-edit-scale-index .scale_options {font-size: 0.8em;}
             
            -.gradetreebox {margin:10px auto;width:90%;}

            Perhaps taking out the whole box could have sense too. Other reports (grader) don't use it at all.

            Just one comment, apart from current integration of PULL-399.

            tsala Helen Foster added a comment -

            Scott, thanks for your report and Andrew, thanks for fixing.

            The issue is fixed in this week's 2.0.2+.


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  5/May/11