Details

    • Type: Sub-task
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0.1
    • Fix Version/s: 2.2
    • Component/s: Themes
    • Environment:
      Firefox 3.6.13 for Ubuntu 10.10.
      Chrome 8.0.552.237 for Ubuntu 10.10 (but without rounded corners, which I thought was odd).
    • Testing Instructions:

      1. Select Anomaly theme and test-drive in modern browsers only.
      2. Test that the left-hand column, in any forum post, is a solid light Gray colour.
      3. Test that the top-right corner of the page header is not broken in IE8, IE9 and Opera
      4. Test docking blocks.
      5. With editing enabled test to see if "Add Block" menu bar sits neatly within the block.

      Show
      1. Select Anomaly theme and test-drive in modern browsers only. 2. Test that the left-hand column, in any forum post, is a solid light Gray colour. 3. Test that the top-right corner of the page header is not broken in IE8, IE9 and Opera 4. Test docking blocks. 5. With editing enabled test to see if "Add Block" menu bar sits neatly within the block.
    • Affected Branches:
      MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_22_STABLE
    • Pull from Repository:
    • Pull Master Branch:

      Description

      The default Anomaly theme as installed with 2.0.1 has some visual inconsistencies when used with forum posts. Please see attached images:

      anomaly.png: a screenshot-snippet of a forum post with the default Anomaly theme and Moodle 2.0.1.
      anomaly-suggested.png: Due to low contrast of colours in first image, I have highlighted the 'block' of colour and squiggled where the colour is missing.
      anomaly-mockup.png: What I believe it should look like (mocked up in GIMP, not patched).

        Gliffy Diagrams

          Attachments

          1. anomaly_mockup.png
            anomaly_mockup.png
            15 kB
          2. anomaly_suggested.png
            anomaly_suggested.png
            15 kB
          3. anomaly.png
            anomaly.png
            14 kB
          4. MDL-26240-Anomaly.jpg
            MDL-26240-Anomaly.jpg
            46 kB

            Activity

            tsala Helen Foster added a comment -

            Setting a fix version of STABLE backlog as part of our triaging process.

            lazydaisy Mary Evans added a comment -

            I've set up MDL-29561 with an aim: To FIX all outstanding issues associated with Anomaly.
            Related Issues:
            MDL-25961 - Anomaly theme should display the course summary below the header.
            MDL-26240 - Anomaly theme inconsistency.
            MDL-26694 - Anomaly theme tabs are not well drawn.

            samhemelryk Sam Hemelryk added a comment -

            Hi Mary,

            I've sending this back presently.
            By adding overflow:hidden on #page you break the theme's ability to overflow horizontally which is important for the report layouts.
            It pays to be very careful with using overflow:hidden on the main content area or any of its parents as you run into these sort of troubles.

            Cheers
            Sam

            lazydaisy Mary Evans added a comment - - edited

            Hi Sam,
            Just read your message!
            Am I too late to reverse this?
            I've just committed the change in general.css in MDL-26240 just this minute!
            Please say it can go thru with the change?

            I have so much more to add to this theme but wanted this cleaning up first!!!

            Cheers
            Mary

            lazydaisy Mary Evans added a comment -

            In deleting old merged branches I deleted this in error!
            Let's hope I have the original files on my computer!

            lazydaisy Mary Evans added a comment -

            @Sam

            I spent 3 hours last night trying to resolve conflicts while re-basing and ended up with a diverging origin/master...which is now in my recycle bin!

            I'm now re-building my Moodle-GIT and working on MDL-26240 ready for submitting today.

            Cheers
            Mary

            lazydaisy Mary Evans added a comment -

            As well as restyling the forumpost left column I also restyled the docking tabs to fit in with the theme colors

            samhemelryk Sam Hemelryk added a comment -

            Hi Mary, I've just been clearing my Email's.
            This issue is on my list for today

            samhemelryk Sam Hemelryk added a comment -

            Hi Mary,
            I've just had a look at this again, its VERY close now.
            Unfortunately there is a nasty bug with the dock.
            A quick glance suggests you should remove the following:

            body.has_dock #page {
                width: 97%;
                right: 3%;
            }

            and instead add:

            body.has_dock {
                margin:0;
            }

            I thought about integrating that as a solution but I think it is best if you have a look and think about it, I may have misinterpreted what you were aiming for.
            Either way seems to be easily to reproduce the bug just by docking a block using Chrome.

            Cheers
            Sam

            lazydaisy Mary Evans added a comment -

            Sam,

            Can you fix this when integrating? If so do it. I did not notice it in resolution 1024 x 768 as I had my screen. Now swapping to Chrome and 1400 x 1050 I can certainly see the BUG...thanks for that.

            Mary

            samhemelryk Sam Hemelryk added a comment -

            Thanks Mary - I made those changes in a commit afterward the integration so all fixed up and in

            rwijaya Rossiani Wijaya added a comment -

            This looks good.

            Test passed.

            stronk7 Eloy Lafuente (stronk7) added a comment -

            The master fixes corresponding to this issue have been sent upstream. Fixes for other branches (19, 20, 21 stable) will be sent in the very-next days.

            Thanks for the hard work! Closing, ciao


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  5/Dec/11