Moodle
  1. Moodle
  2. MDL-26255

Testgen import for math symbols and notation

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Duplicate
    • Affects Version/s: 1.9.10, 2.2
    • Fix Version/s: None
    • Component/s: Questions
    • Labels:
    • Affected Branches:
      MOODLE_19_STABLE, MOODLE_22_STABLE
    • Rank:
      15869

      Description

      Testgen imports of Math questions has to be done manually or once they are imported they do not come up correctly.
      Work around is manually done by doing gift format import http://docs.moodle.org/en/GIFT and directions from the testgen
      In TestGen:

      1. Create an web test in Blackboard format.
      2. EXPORT (not Save) the quiz as a Blackboard File.
      3. This will create a .zip folder - best to save it to your desktop
      for easy finding in Moodle.
      4. Unzip the folder on your desktop.

      In Your Course in Moodle:

      1. Create your Quiz
      2. In the 1st window (preferences) choose your settings and hit "Continue"
      3. In the next window - under "Create New Question" click on the
      "Import Questions from File" link
      4. In this next window - choose "Blackboard" (not Blackboard 6+)
      format from the drop down menu.
      5. Click on "Browse" and go INTO the unzipped folder and choose the
      file ending in ".dat"
      6. Upload the file.

      When there is multiple questions this is more time consuming and we need improvements made to make this eaiser on instructors.

        Issue Links

          Activity

          Jean-Michel Vedrine added a comment -

          Hello sandra,
          Can you post an example of a Testgen math Questions, so that I can have a look at the format and work on a solution.
          Thanks

          Tim Hunt added a comment -

          Since testgen import uses the Blackboard importers, this is effectively a duplicate of MDL-25492, which should be fixed next week.


            People

            • Votes:
              1 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: