Moodle
  1. Moodle
  2. MDL-26272

Recent changes in modinfo caused some regressions

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 2.0.1
    • Fix Version/s: 2.0.2
    • Component/s: Libraries, Ratings
    • Labels:
    • Difficulty:
      Moderate
    • Affected Branches:
      MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE
    • Rank:
      16348

      Description

      Recent changes in modinfo (MDL-25981) have caused the $cm objects to stop providing $cm->context.

      It breaks at least all the places were ratings are used because they rely on that:

      mod/data/view.php: $ratingoptions->context = $cm->context;
      mod/forum/lib.php: $ratingoptions->context = $cm->context;
      mod/glossary/view.php: $ratingoptions->context = $cm->context;

      There are also some other uses (12) of:

      $PAGE->cm->context

      But they continue working so we can keep them unmodified for now.

      Going to fix the 3 broken places NOW, hopefully there aren't more places.

      Ciao

        Issue Links

          Activity

          Eloy Lafuente (stronk7) added a comment -

          resolving as fixed... going towards the pull request way...

          Helen Foster added a comment -

          Thanks Sol!


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: