Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-26302

Move button on the quiz 'Order and Paging' tab does not work

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0.1, 2.1.1, 2.2
    • Fix Version/s: 2.0.5, 2.1.2
    • Component/s: Quiz
    • Labels:
    • Testing Instructions:

      1. Go to the edit page for a quiz with no student attempts.

      2. Go to the order and paging tab.

      3. Use the Move selected questions to page controls to move questions around in the quiz layout. Verify that the controls both at the top and the bottom of the page work.

      Show
      1. Go to the edit page for a quiz with no student attempts. 2. Go to the order and paging tab. 3. Use the Move selected questions to page controls to move questions around in the quiz layout. Verify that the controls both at the top and the bottom of the page work.
    • Affected Branches:
      MOODLE_20_STABLE, MOODLE_21_STABLE, MOODLE_22_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE, MOODLE_21_STABLE
    • Pull from Repository:
    • Pull Master Branch:

      Description

      The 'Move' button on the 'Order and paging' tab of a quiz appears to have no effect.

      Steps to reproduce:

      • In a quiz, select 'Edit quiz' from the Settings block. Add questions if necessary.
      • Click 'Order and paging' tab
      • Select a question
      • Type a valid page number into the field next to 'Move' button (attached image 1)
      • Click 'Move' button

      Expectation: Selected question should be moved to specified page
      Result: All fields are cleared, but question does not move. (attached image 2)

        Gliffy Diagrams

          Attachments

          1. order_01.gif
            order_01.gif
            12 kB
          2. order_02.gif
            order_02.gif
            12 kB
          3. page_move.diff
            1 kB

            Issue Links

              Activity

              tcubanski Tom Cubanski added a comment -

              This problem also exists in Moodle 2.1. The form in this page uses the same name for the text field on the top as the text field on the bottom. The value of the field at the bottom of the page always overrides anything in the field at the top, even if the bottom field is blank. It looks like the author
              intended these fields to have different names. The attached patch fixes the
              problem.

              timhunt Tim Hunt added a comment -

              Thanks Tom for this fix. Sorry it took so long for me to review it.

              stronk7 Eloy Lafuente (stronk7) added a comment -

              The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

              TIA and ciao

              stronk7 Eloy Lafuente (stronk7) added a comment -

              Integrated, thanks!

              samhemelryk Sam Hemelryk added a comment -

              Thanks Tim, giving this a pass.

              However did find another notice although this one you may not care about.
              If I select a question, and in the `Move selected questions to page` text field enter a number greater than the number of pages (a page that doesn't exist of course) then I get the following:

              Notice: Undefined offset: 5 in mod/quiz/edit.php on line 361

              Is this something you are aware of/care about?

              Cheers
              Sam

              timhunt Tim Hunt added a comment -

              Yes, of course I care. That is a (separate) bug. Please create a new issue for me. Thanks.

              samhemelryk Sam Hemelryk added a comment -

              Have created MDL-29176 for the notice

              stronk7 Eloy Lafuente (stronk7) added a comment -

              git & cvs repositories have been populated with this solution. Many thanks for your collaboration, yay!

              Closing, ciao


                People

                • Votes:
                  0 Vote for this issue
                  Watchers:
                  2 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    10/Oct/11