Moodle
  1. Moodle
  2. MDL-26311

Some inconsistencies across data/forum/glossary rss feeds

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: 2.0.1
    • Fix Version/s: STABLE backlog
    • Component/s: RSS
    • Labels:
    • Difficulty:
      Moderate
    • Affected Branches:
      MOODLE_20_STABLE
    • Rank:
      15910

      Description

      While reviewing MDL-24870 (PULL-223), I've detected some inconsistencies / problems in the RSS feeds generated by activities:

      1. admins/managers cannot, anymore, access to glossary feeds (is_enrolled() is used now). Both data and forum use capability check instead.
      2. forum is missing the "RSS feed for this activity" option in the navigation block. Both data and glossaries show it.
      3. This point has been moved to MDL-26500: glossary and forum images in feeds aren't shown ok. The URL contains untranslated @@PLUGINFILE@@. It seems that data images (based on field) are working ok.

      Ciao

        Issue Links

          Activity

          Glenn Ansley added a comment -

          Hi Eloy,
          I was doing some testing and I wasn't able to reproduce issues number 1 and 2 above but I could reproduce issue number 3.

          I was able to track down the location of that content generation in mod/glossary/rsslib.php and confirm that the definition was not being passed through the file_rewrite_pluginfile_urls() function. Doing so (like in the below diff) fixes the problem but it requires the viewer to be logged in to see the image. I assume we would need to find some way to authenticate file permission based on the RSS tokens rather than checking to see if the viewer is logged in and enrolled in the course. Is this possible with the file API? I can continue hunting but I was wondering if anyone had a preferred method for me to pursue or any other recommendations. Thanks.

          https://github.com/glennansley/moodle/commit/3d6258ebdadd412bdf1d4f648662c034ba1de58a

          Eloy Lafuente (stronk7) added a comment -

          Hi, about the (3) reported above... Let's continue with it @ MDL-26500.

          Andrew Davis added a comment -

          This issue was assigned to me automatically, however I will not be able to work on this issue in the immediate future. In order to create a truer sense of the state of this issue and to allow other developers to have chance to become involved, I am removing myself as the assignee of this issue.

          For more information, see http://docs.moodle.org/dev/Changes_to_issue_assignment

          Andrew Davis added a comment -

          I am closing this issue. I believe these issues have been dealt with since this issue was created.


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: