Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-26329

Images are saved/transformed under brokenfile.php

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 2.0.1
    • Fix Version/s: 2.0.2
    • Component/s: Files API
    • Labels:
    • Environment:
      Nginx 0.8.54/php-fpm in php 5.3.3/ubuntu 10.04 TDS/postgres9.0.3
    • Database:
      PostgreSQL
    • Affected Branches:
      MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE

      Description

      • I create a label
      • I add a file in the tinymce editor (upload from my hard drive)
      • I save the label (till the moment the image was well displayed in the editor, and the link was /draftfile.php?file=%2F13%2Fuser%2Fdraft%2F742726817%2Fffdgfd)

      => the label doesn't display the image correctly because it is /brokenfile.php#?file=%2F13%2Fuser%2Fdraft%2F742726817%2Fffdgfd
      If I try to edit the label I can still see brokenfile.php

      This is a generic problem not specific to label (it can be reproduced with forum, course,...)

      thank you.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              skodak Petr Skoda added a comment -

              The problem is that the file postprocessing code does not detect the draftfile urls with ?file= parameter properly.

              Yay! this is probably reason of many reports of broken images in 2.0.x....

              jerome Jérôme Mouneyrac added a comment -

              I don't know if it helps but I noticed if the first time I create the label I change:
              /draftfile.php?file=%2F13%2Fuser%2Fdraft%2F742726817%2Fffdgfd => /draftfile.php?file=/13/user/draft/742726817/ffdgfd then it is well recorded and the image is well displayed.

              If I edit after creating the label without fixing the url, and if then I try to change the /brokenfile.php#?file=%2F13%2Fuser%2Fdraft%2F742726817%2Fffdgfd => /draftfile.php?file=/13/user/draft/742726817/ffdgfd then it's still broken.

              skodak Petr Skoda added a comment -

              Pull submitted, thanks a lot for the report!

              sstrauss@haverford.edu Sharon Strauss added a comment -

              Hello,

              I know this bug is closed, I am seeing this same issue in Moodle 3.0.5 using the ATTO editor.
              Should I open a new ticket?

              marina Marina Glancy added a comment -

              yes please create a new issue and add as many details as possible


                People

                • Votes:
                  0 Vote for this issue
                  Watchers:
                  4 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    21/Feb/11