Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-26359

Groups and Groupings are missing from restored courses

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.0.1
    • Fix Version/s: None
    • Component/s: Backup, Groups
    • Labels:
      None
    • Affected Branches:
      MOODLE_20_STABLE

      Description

      I have tested on 2 builds 20110125 and 20110209 (qa site)
      If I backup a course with groups (including user data) and then restore - then groups will be missing from a new course.
      On my own instance 20110125 I somehow got one of the two groups re-created during one of the tests.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              stronk7 Eloy Lafuente (stronk7) added a comment -

              Hi Elena, thanks for the report!

              Can you provide me with one backup where the problem is reproducible? I've tested here with two courses and I get both groups and groupings working ok. Of course, keep out any not-needed activity and/or anonymize the users (that should keep privacy ok).

              Ciao

              elenaivanova Elena Ivanova added a comment -

              here, right from the QA site
              "empty" one has just users and role assignments.
              "withactivities" has the full course

              libertymoodle Luis de Vasconcelos added a comment - - edited

              I tried to restore a 2.0.2+ course backup into my 2.0.2+ (Build: 20110316) instance of Moodle (Windows Server 2003, IIS 6, MSSQL 2005) and my Groups are also missing.

              If I look inside the .mbz file it has a groups.xml which is "empty" and doesn't include any of my groups:

              <?xml version="1.0" encoding="UTF-8"?>
              <groups>
              <groupings>
              </groupings>
              </groups>

              Is this correct? Or should it have tags for each of my groups?

              I've attached backup-moodle2-course-crs_ltbrmg-20110323-1612-nu.mbz which is a backup of the test course that I created to test this.

              mkemmerling Markus Kemmerling added a comment -

              This seems to be related to #MDL-26472. See the proposed fix.

              A group is only added to groups.xml if it is referenced by any inforef.xml. If you add, e.g., a post by some user to a forum in group mode, the users' group will probably be added to groups.xml.

              stronk7 Eloy Lafuente (stronk7) added a comment -

              This issue was assigned to me automatically, however I will not be able to work on this issue in the immediate future. In order to create a truer sense of the state of this issue and to allow other developers to have chance to become involved, I am removing myself as the assignee of this issue.

              For more information, see http://docs.moodle.org/dev/Changes_to_issue_assignment

              marina Marina Glancy added a comment -

              I believe this has been fixed 3 years ago in MDL-27438. Closing the issue


                People

                • Votes:
                  1 Vote for this issue
                  Watchers:
                  5 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: