Moodle
  1. Moodle
  2. MDL-26404

Moodle 2 Messaging Interface (Search bar overlap)

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0.1
    • Fix Version/s: 2.0.3
    • Component/s: Messages
    • Labels:
    • Affected Branches:
      MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE
    • Rank:
      16105

      Description

      When a contact is added to the My Contacts list, the divider line and search field overlap the drop down list. This appears to be a resizing issue. When this interface is viewed on a large screen, the fields do not overlap. When the font is changed to a smaller size, the overlapping is slightly less.

      The screenshot displays a custom theme, however, the default Moodle 2 themes display the same overlapping issue.

        Issue Links

          Activity

          Andrea Brevard added a comment -

          Mary from NewSchool came back with a core.css that adjusted the margins further and fixed the overlap when a smaller font size is used. This issue can be closed.

          Andrew Davis added a comment -

          Hello Andrea. Is there any chance you could post the fix for anyone else that may experience the same problem in future?

          Mary Evans added a comment -

          This problem has nothing to do with adding contacts, it is caused by the 'Course Short Name' being TOO LONG! There should be a MAX number of 25 characters ONLY set in course/edit.php when editing course settings. In the image I have uploaded you can see what the maximum length is in this example text: "Lorem ipsum dolor sit amet, consectetur adipiscing elit. Aenean eu metus quis dui semper scelerisque", which is the same text I use in the test I carried out to show what the extent of this problem really is.

          Andrea Brevard brought this to my attention the other day, but I have only just managed to find time to test it fully. In Andrea's case, her site has an added problem in that the font is 10% larger than normal, thus causing a bigger that average problem.

          Mary Evans added a comment -

          @Andrew,
          This is a core issue and no amount of CSS styling is going to fix it. CSS styling will work for a little while, but if someone adds a longer name then the problem with get worse.

          Andrew Davis added a comment - - edited

          Ah, ok. I understand the problem. I'm not sure about limiting the maximum length of course short name. That seems to make sense but I'll need to discuss this with some more people as I get the feeling someone somewhere will have a good reason why that's a bad idea.

          As an alternative we may just trim the course short name within the messaging UI. Ive quickly coded that up. That code is at...
          repo: git://github.com/andyjdavis/moodle.git
          branch: MDL-26404_nav_too_wide
          diff: https://github.com/andyjdavis/moodle/compare/master...MDL-26404_nav_too_wide

          Mary Evans added a comment -

          Super brilliant! Glad to see this has been fixed. You make coding look so easy!
          Will this fix be included in Moodle 2.2, which I understand is due out tomorrow?

          Many thanks
          Mary

          Andrew Davis added a comment -

          Ive created a pull request to get this reviewed for integration.

          Mary, this probably won't be in 2.0.2 unless the release of 2.0.2 is delayed for some reason.

          Eloy Lafuente (stronk7) added a comment -

          Rejected because of PULL-339 not being utf-8 compliant. Easy to fix, thanks!

          Andrew Davis added a comment -

          fixed PULL-354

          Helen Foster added a comment -

          Thanks for everyone's comments. This issue is fixed in the latest Moodle 2.0.2+ weekly.

          Mark Berthelemy added a comment -

          Hi all,
          I'm using version 2.0.3+ (Build: 20110518) and long course short names are still messing around with the layout - the drop down is extending so it's covered by the search box. I'm using an adapted theme, based on Boxxie, but with no changes to layout. Using IE7 (sorry - I have to).

          Any ideas?

          Thanks,

          Mark

          Mary Evans added a comment -

          Yes, I suggest you ask this question in the Themes' Forum, as this issue is closed.

          http://moodle.org/mod/forum/view.php?id=46

          Thanks
          Mary

          Andrew Davis added a comment -

          Mark, as Mary suggests try the forums. If you're sure its a Moodle code problem open a new issue in tracker. Once an issue is closed they are very rarely raised from the dead so a new issue is your best bet.


            People

            • Votes:
              2 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: