Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-26405

invalid exception in backup code

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 2.0.1
    • Fix Version/s: 2.0.2
    • Component/s: Backup
    • Labels:
    • Affected Branches:
      MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE

      Description

      throw restore_step_exception('error_question_answers_missing_in_db', $info);
      in restore_qtype_plugin.calss.php

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              skodak Petr Skoda created issue -
              stronk7 Eloy Lafuente (stronk7) made changes -
              Field Original Value New Value
              Link This issue is duplicated by MDL-25903 [ MDL-25903 ]
              stronk7 Eloy Lafuente (stronk7) made changes -
              Status Open [ 1 ] In Progress [ 3 ]
              stronk7 Eloy Lafuente (stronk7) made changes -
              Link This issue will be resolved by PULL-317 [ PULL-317 ]
              stronk7 Eloy Lafuente (stronk7) added a comment -

              Marking as fixed (PULL request created).

              I've been investigating why Helen was getting that error @ qa.moodle.net and concluded it was caused because yesterday I was preparing various backup files for help testing different pull requests, and I ended borking them.

              Today I've re-attached double-verified backup files to all those requests.

              So this is simple: Just add the missing "new" keyword.

              Ciao

              stronk7 Eloy Lafuente (stronk7) made changes -
              Status In Progress [ 3 ] Ready for review [ 10010 ]
              Fix Version/s 2.0.2 [ 10421 ]
              Resolution Fixed [ 1 ]
              stronk7 Eloy Lafuente (stronk7) made changes -
              Labels pullweek-2011-07
              stronk7 Eloy Lafuente (stronk7) made changes -
              Link This issue will be resolved by PULL-319 [ PULL-319 ]
              stronk7 Eloy Lafuente (stronk7) added a comment -

              Take two. Finally I've been able to reproduce the problem happening @ qa.moodle.net in my dev environment and, after a bit more of debugging, I've found the cause and, hopefully, the fix.

              So I've created PULL-319 to get this addressed ASAP. To reproduce the problem simply get any backup file containing questions and, on restore, uncheck the "activities" setting.

              Before the patch it was breaking badly, after the patch it should finish smoothly!

              Thanks! Ciao

              stronk7 Eloy Lafuente (stronk7) added a comment -

              Raising to critical as far as it causes any backup to be, depending of the settings, unrestorable.

              stronk7 Eloy Lafuente (stronk7) made changes -
              Priority Minor [ 4 ] Critical [ 2 ]
              stronk7 Eloy Lafuente (stronk7) made changes -
              Labels pullweek-2011-07 triaged
              stronk7 Eloy Lafuente (stronk7) made changes -
              Link This issue is duplicated by MDL-26442 [ MDL-26442 ]
              tsala Helen Foster made changes -
              Status Ready for review [ 10010 ] Closed [ 6 ]
              dougiamas Martin Dougiamas made changes -
              Workflow MDL Workflow [ 67758 ] MDL Full Workflow [ 96132 ]

                People

                • Votes:
                  0 Vote for this issue
                  Watchers:
                  3 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    21/Feb/11