Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-26431

Course completion report columns not lining up.

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0.1
    • Fix Version/s: 2.0.6, 2.1.3
    • Component/s: Course completion
    • Labels:
      None
    • Testing Instructions:

      Turn on completion in advanced site settings
      Create course with completion enabled
      Enrol 1 or more users
      Add completion criteria to course (via Completion form in course admin)
      Enabled idnumbers in grade reports via Admin grade report settings.
      View completion course report.

      Without patch, report table headings will be misaligned.
      With patch, report table heading will be correctly aligned.

      Show
      Turn on completion in advanced site settings Create course with completion enabled Enrol 1 or more users Add completion criteria to course (via Completion form in course admin) Enabled idnumbers in grade reports via Admin grade report settings. View completion course report. Without patch, report table headings will be misaligned. With patch, report table heading will be correctly aligned.
    • Affected Branches:
      MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE, MOODLE_21_STABLE
    • Pull from Repository:

      Description

      The idnumber column is causing the course completion report columns to not line up correctly. There needs to be a blank header for the idnumber column for the other completion method columns to line up correctly. See attached image.

        Gliffy Diagrams

          Activity

          jrh18 Jason Hardin added a comment -

          This is specifically due to the admin/settings.php?section=gradereportgrader setting Show user ID numbers
          grade_report_showuseridnumber being enabled for the site. This adds the id number column to the body of the report without adding something to the headers.

          sry_not4sale Aaron Barnes added a comment -

          This patch looks unnecessary for HEAD where they have made some changes to reports and user data.

          samhemelryk Sam Hemelryk added a comment -

          Thanks guys this has been integrated now. Confirmed its not needed in master anymore.

          samhemelryk Sam Hemelryk added a comment -

          Tested during integration - thanks guys

          stronk7 Eloy Lafuente (stronk7) added a comment -

          And this has landed upstream, just on time for the upcoming new releases week. Thanks for it!

          Ciao


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Fix Release Date:
                28/Nov/11