Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-26502

'Symbian' is misspelt, so browser check gives false positives

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Trivial
    • Resolution: Fixed
    • Affects Version/s: 1.9.10, 2.0
    • Fix Version/s: 1.9.12, 2.0.3
    • Component/s: Libraries
    • Labels:
      None
    • Environment:
      n/a
    • Difficulty:
      Easy
    • Affected Branches:
      MOODLE_19_STABLE, MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_19_STABLE, MOODLE_20_STABLE

      Description

      'Symbian' is misspelt as 'Simbian' in moodlelib.php

      This means that some phones that should be rejected are accepted as having qualifying user agents.

      For example, with the user agent string for a Nokia N97:

      Mozilla/5.0 (SymbianOS/9.4; Series60/5.0 NokiaN97-1/12.0.024; Profile/MIDP-2.1 Configuration/CLDC-1.1; en-us) AppleWebKit/525 (KHTML, like Gecko) BrowserNG/7.1.12344

      check_browser_version('Safari') returns true. The expected behaviour is that it would return false, rejecting the phone due to the term 'SymbianOS' in the UA string.

        Gliffy Diagrams

        1. testua.php
          0.3 kB
          Daren Chandisingh

          Activity

          tsala Helen Foster added a comment -

          Fixed in the latest 2.0.2+ and 1.9.11+ weekly. Many thanks Daren.


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Fix Release Date:
                5/May/11