Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-26505

Overall quiz grades are rounded before storing in the database

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 1.9.11
    • Fix Version/s: 1.9.12
    • Component/s: Questions, Quiz
    • Labels:
    • Affected Branches:
      MOODLE_19_STABLE
    • Fixed Branches:
      MOODLE_19_STABLE

      Description

      Steps to reproduce:

      1. Create a quiz with overall feedback <7 below 70% >7 above 70%, grades displayed to 0 decimal places.
      2. Add one essay question to the quiz, worth 1 mark, quiz graded out of 10.
      3. Attempt the quiz as a student.
      4. As a teacher, manually grade the question as 0.69 / 1.
      5. Check the quiz reports. Student 1 7 feedback <7, overall average 7, >7.

      Something has gone wrong with the feedback for the average, and the cause is that the grade was rounded before being stored in the quiz_grades table.

      This bug does not occur in Moodle 2.0.x.

        Gliffy Diagrams

          Attachments

            Activity

            timhunt Tim Hunt added a comment -

            Pull request done.

            tsala Helen Foster added a comment -

            Thanks Tim.


              People

              • Assignee:
                timhunt Tim Hunt
                Reporter:
                timhunt Tim Hunt
                Tester:
                Eloy Lafuente (stronk7)
                Participants:
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  10/May/11