Moodle
  1. Moodle
  2. MDL-26523

Various problems found with the grader report in gradebook

    Details

    • Database:
      Any
    • Testing Instructions:

      As always make sure your test site is set to show all errors etc. You'll need a course with at least one activity that uses a custom scale.

      Go to the grader report for the course. Turn on editing.

      Click one of the hand/pencil icons for a student grade for the activity using a custom scale. If MDL-26275 has been integrated you should only have to click it once. If it hasn't been integrated you will have to click it twice.

      No missing string errors should be displayed.

      Show
      As always make sure your test site is set to show all errors etc. You'll need a course with at least one activity that uses a custom scale. Go to the grader report for the course. Turn on editing. Click one of the hand/pencil icons for a student grade for the activity using a custom scale. If MDL-26275 has been integrated you should only have to click it once. If it hasn't been integrated you will have to click it twice. No missing string errors should be displayed.
    • Affected Branches:
      MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_21_STABLE, MOODLE_22_STABLE
    • Pull Master Branch:
      MDL-26523_grader
    • Rank:
      16113

      Description

      Detected while testing @ MDLQA-683

      1) Using AJAX in the grader report, it seems that 2 fields should be shown when overriding one grade (grade and comment), but I'm only getting one field (grade) and the comment one isn't present.

      2) Two clicks are necessary in the "hand with one pencil" icon in order to get the override grade_grade form page. With one click nothing is launched / requested.

      3) When the override grade_grade page is invoked for one "scale item", some strings seem to be missing:

      Help title string does not exist: [finalgrade, finalgrade]
      
          * line 351 of /lib/outputcomponents.php: call to debugging()
          * line 1678 of /lib/outputrenderers.php: call to help_icon->diag_strings()
          * line 1507 of /lib/formslib.php: call to core_renderer->help_icon()
          * line 76 of /grade/edit/tree/grade_form.php: call to MoodleQuickForm->addHelpButton()
          * line 152 of /lib/formslib.php: call to edit_grade_form->definition()
          * line 98 of /grade/edit/tree/grade.php: call to moodleform->moodleform()
      
      Help contents string does not exist: [finalgrade_help, finalgrade]
      
          * line 354 of /lib/outputcomponents.php: call to debugging()
          * line 1678 of /lib/outputrenderers.php: call to help_icon->diag_strings()
          * line 1507 of /lib/formslib.php: call to core_renderer->help_icon()
          * line 76 of /grade/edit/tree/grade_form.php: call to MoodleQuickForm->addHelpButton()
          * line 152 of /lib/formslib.php: call to edit_grade_form->definition()
          * line 98 of /grade/edit/tree/grade.php: call to moodleform->moodleform()
      
      Invalid get_string() identifier: 'finalgrade' or component 'finalgrade'
      
          * line 5863 of /lib/moodlelib.php: call to debugging()
          * line 6418 of /lib/moodlelib.php: call to core_string_manager->get_string()
          * line 1698 of /lib/outputrenderers.php: call to get_string()
          * line 70 of /lib/outputrenderers.php: call to core_renderer->render_help_icon()
          * line 1684 of /lib/outputrenderers.php: call to renderer_base->render()
          * line 1507 of /lib/formslib.php: call to core_renderer->help_icon()
          * line 76 of /grade/edit/tree/grade_form.php: call to MoodleQuickForm->addHelpButton()
          * line 152 of /lib/formslib.php: call to edit_grade_form->definition()
          * line 98 of /grade/edit/tree/grade.php: call to moodleform->moodleform()
      

      Ciao

        Issue Links

          Activity

          Eloy Lafuente (stronk7) created issue -
          Eloy Lafuente (stronk7) made changes -
          Field Original Value New Value
          Link This issue will help resolve MDLQA-683 [ MDLQA-683 ]
          Martin Dougiamas added a comment -

          This is a really badly-named issue ... How can anyone triage it?

          Eloy Lafuente (stronk7) added a comment -

          By reading?

          Martin Dougiamas made changes -
          Workflow MDL Workflow [ 68111 ] MDL Full Workflow [ 75953 ]
          Andrew Davis added a comment -

          #1 is dependent on the site setting grade_report_showquickfeedback. Just did some testing and it seems to be working fine now.

          #2 the first time you click the hand/pencil icon the following JS error is reported.

          Error: this.gradespan is null
          Source File: http://localhost/moodle/dev/master/grade/report/grader/module.js
          Line: 981

          #3 missing string error reproduced.

          Andrew Davis made changes -
          Testing Instructions As always make sure your test site is set to show all errors etc. You'll need a course with at least one activity that uses a custom scale.

          Go to the grader report for the course. Turn on editing.

          Click one of the hand/pencil icons for a student grade for the activity using a custom scale. Click it once and only once. The Edit grade should load.

          No missing string errors should be displayed.
          Database Any [ 10000 ]
          Andrew Davis made changes -
          Andrew Davis added a comment -

          Ive fixed the missing string problem.

          Regarding the JS problem I'm doing quite a bit of work on the grader report's JS in MDL-26275. I just went and did some testing and it looks like I've already fixed this issue in that issue.

          Putting this up for peer review.

          Andrew Davis added a comment -

          Ive updated the testing instructions and will add a check for the JS error to MDL-26275's testing instructions.

          Andrew Davis made changes -
          Testing Instructions As always make sure your test site is set to show all errors etc. You'll need a course with at least one activity that uses a custom scale.

          Go to the grader report for the course. Turn on editing.

          Click one of the hand/pencil icons for a student grade for the activity using a custom scale. Click it once and only once. The Edit grade should load.

          No missing string errors should be displayed.
          As always make sure your test site is set to show all errors etc. You'll need a course with at least one activity that uses a custom scale.

          Go to the grader report for the course. Turn on editing.

          Click one of the hand/pencil icons for a student grade for the activity using a custom scale. If MDL-26275 has been integrated you should only have to click it once. If it hasn't been upgraded you will have to click it twice.

          No missing string errors should be displayed.
          Andrew Davis made changes -
          Testing Instructions As always make sure your test site is set to show all errors etc. You'll need a course with at least one activity that uses a custom scale.

          Go to the grader report for the course. Turn on editing.

          Click one of the hand/pencil icons for a student grade for the activity using a custom scale. If MDL-26275 has been integrated you should only have to click it once. If it hasn't been upgraded you will have to click it twice.

          No missing string errors should be displayed.
          As always make sure your test site is set to show all errors etc. You'll need a course with at least one activity that uses a custom scale.

          Go to the grader report for the course. Turn on editing.

          Click one of the hand/pencil icons for a student grade for the activity using a custom scale. If MDL-26275 has been integrated you should only have to click it once. If it hasn't been integrated you will have to click it twice.

          No missing string errors should be displayed.
          Andrew Davis made changes -
          Status Open [ 1 ] Waiting for peer review [ 10012 ]
          Andrew Davis made changes -
          Fix Version/s STABLE Sprint 20 [ 12152 ]
          Dan Poltawski made changes -
          Original Estimate 0 minutes [ 0 ]
          Remaining Estimate 0 minutes [ 0 ]
          Status Waiting for peer review [ 10012 ] Peer review in progress [ 10013 ]
          Peer reviewer poltawski
          Dan Poltawski added a comment -

          Looks good +1

          Dan Poltawski made changes -
          Status Peer review in progress [ 10013 ] Development in progress [ 3 ]
          Andrew Davis added a comment -

          Adding branches and putting this up for integration.

          Andrew Davis made changes -
          Status Development in progress [ 3 ] Waiting for integration review [ 10010 ]
          Eloy Lafuente (stronk7) added a comment -

          The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

          TIA and ciao

          Sam Hemelryk made changes -
          Currently in integration Yes [ 10041 ]
          Sam Hemelryk made changes -
          Status Waiting for integration review [ 10010 ] Integration review in progress [ 10004 ]
          Integrator samhemelryk
          Sam Hemelryk added a comment -

          Thanks Andrew, this has been integrated now

          Sam Hemelryk made changes -
          Status Integration review in progress [ 10004 ] Waiting for testing [ 10005 ]
          Fix Version/s 2.1.6 [ 12052 ]
          Fix Version/s 2.2.3 [ 12053 ]
          Michael de Raadt made changes -
          Tester salvetore
          Michael de Raadt made changes -
          Tester salvetore fred
          Frédéric Massart made changes -
          Status Waiting for testing [ 10005 ] Testing in progress [ 10011 ]
          Frédéric Massart added a comment -

          Successfully tested on 2.1, 2.2 and master

          Frédéric Massart made changes -
          Status Testing in progress [ 10011 ] Tested [ 10006 ]
          Eloy Lafuente (stronk7) added a comment -
          UPDATE tracker_issues
             SET status = 'Closed',
                comment = 'Thanks!'
          WHEN participants = 'Did a gorgeous work'
          

          This landed upstream some hours ago (some - me - developer fell slept in the sofa yesterday before spamming this).

          Eloy Lafuente (stronk7) made changes -
          Status Tested [ 10006 ] Closed [ 6 ]
          Resolution Fixed [ 1 ]
          Currently in integration Yes [ 10041 ]
          Integration date 04/May/12
          Ankit Agarwal made changes -
          Link This issue is duplicated by MDL-32166 [ MDL-32166 ]
          Eloy Lafuente (stronk7) made changes -
          Fix Version/s STABLE Sprint 20 [ 12152 ]

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: