Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.0, 2.0.1
    • Fix Version/s: 2.0.3
    • Component/s: Feedback
    • Labels:
      None
    • Database:
      Any
    • Affected Branches:
      MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE

      Description

      If a feedback uses groups and a multiple-choice question is set to "Do not analyse empty submits" then a database error is shown on filtering by group.

        Gliffy Diagrams

          Attachments

            Activity

            grabs Andreas Grabs added a comment -

            You can test this issue:

            • create one or more groups in your course
            • put two or more students in each group
            • create a feedback (nonanonymous)
            • set the feedback to use groups
            • create a question type: Multiple Choice (rated) with two or more options. The setting "Do not analyse empty submits" you have to set "Yes".
            • do a submit with each student
            • go to the "Analysis"-Page
            • choose a group in the group-list
              Now the error will be shown.
              The issue is a small typo in the lib.php on line 2114.
            tsala Helen Foster added a comment -

            Andreas, thanks for fixing.


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  5/May/11