Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-26525

Deleting one lesson attempt doesn't delete its grade in gradebook but sets it to 0

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Cannot Reproduce
    • Affects Version/s: 2.0.1
    • Fix Version/s: None
    • Component/s: Gradebook, Lesson
    • Labels:
    • Difficulty:
      Moderate
    • Affected Branches:
      MOODLE_20_STABLE

      Description

      Detected testing MDLQA-730

      When one lesson attempt is deleted from the lesson -> reports page, the corresponding grade in gradebook should disappear (not exist). Instead it is set to 0, so it's take into account for aggregations and so on.

      TODO: Fix this
      TODO: Review other modules's behavior
      TODO: Back port to 1.9 if possible

      Ciao

        Gliffy Diagrams

          Activity

          ankit_frenz Ankit Agarwal added a comment -

          Adding Andrew for some feedback

          I tested this with a lesson and a scorm pack
          In both cases the entries were deleted from grade_item table and entries were created in grade_history table.
          Also looked at the code grade_update is being called with deleted flag, which in turn deletes the entries (class grade_object)
          I donot see this being an issue anymore

          Thanks

          andyjdavis Andrew Davis added a comment -

          Sounds like its been fixed at some point. Close it as "cannot reproduce" or whatever you see fit. If you can find the issue that fixed it that's great but otherwise just close it. Make sure to remove the fix version so that this issue wont appear in the release notes.

          ankit_frenz Ankit Agarwal added a comment -

          Thanks Andrew for the confirmation.
          Closing this as suggested.
          Thanks


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: