Moodle
  1. Moodle
  2. MDL-26528

Problem restoring forums with wrong forum_read information

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 1.9.10
    • Fix Version/s: 1.9.12
    • Component/s: Backup, Forum
    • Labels:
    • Difficulty:
      Moderate
    • Affected Branches:
      MOODLE_19_STABLE
    • Fixed Branches:
      MOODLE_19_STABLE
    • Rank:
      16269

      Description

      Following this comment:

      http://tracker.moodle.org/browse/MDL-15489?focusedCommentId=103770&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-103770

      and thanks to Stephen Martin for his collaboration, I was able to trace the problem of some "Restore fails: Could not restore modules" error caused by some forum_read records belonging to people not being part of the course (admins...).

      So I've introduced one small change to the restore in order to allow the process to continue by simply skipping that (orhpan) forum_read record, instead of returning error.

      Ciao

        Issue Links

          Activity

          Hide
          Eloy Lafuente (stronk7) added a comment -

          I've created PULL-337 for integration of the solution this week. So, if accepted, it will be available next Wednesday once the review and testing ends and new weekly versions are available.

          Many thanks Stephen for the complete information!

          Show
          Eloy Lafuente (stronk7) added a comment - I've created PULL-337 for integration of the solution this week. So, if accepted, it will be available next Wednesday once the review and testing ends and new weekly versions are available. Many thanks Stephen for the complete information!
          Hide
          Helen Foster added a comment -

          This bug is fixed in the latest 1.9.11+ weekly. Thanks Eloy for your report, fix, pull request, integration review and QA testing!

          Show
          Helen Foster added a comment - This bug is fixed in the latest 1.9.11+ weekly. Thanks Eloy for your report, fix, pull request, integration review and QA testing!
          Hide
          Eloy Lafuente (stronk7) added a comment -

          Yeah, was anything but "orthodox".

          Show
          Eloy Lafuente (stronk7) added a comment - Yeah, was anything but "orthodox".

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: