Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-26528

Problem restoring forums with wrong forum_read information

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 1.9.10
    • Fix Version/s: 1.9.12
    • Component/s: Backup, Forum
    • Labels:
    • Difficulty:
      Moderate
    • Affected Branches:
      MOODLE_19_STABLE
    • Fixed Branches:
      MOODLE_19_STABLE

      Description

      Following this comment:

      http://tracker.moodle.org/browse/MDL-15489?focusedCommentId=103770&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-103770

      and thanks to Stephen Martin for his collaboration, I was able to trace the problem of some "Restore fails: Could not restore modules" error caused by some forum_read records belonging to people not being part of the course (admins...).

      So I've introduced one small change to the restore in order to allow the process to continue by simply skipping that (orhpan) forum_read record, instead of returning error.

      Ciao

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              stronk7 Eloy Lafuente (stronk7)
              Reporter:
              stronk7 Eloy Lafuente (stronk7)
              Tester:
              Eloy Lafuente (stronk7)
              Participants:
              Component watchers:
              Adrian Greeve, Jake Dallimore, Mathew May, Mihail Geshoski, Peter Dias, Andrew Nicols, Jun Pataleta, Michael Hawkins, Shamim Rezaie, Simey Lameze
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Fix Release Date:
                10/May/11